summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-25 16:53:25 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-25 16:53:25 +0000
commit96769bef6b6758fe45f70ae1e01983fe117ed59b (patch)
treee747d3242c0f1bf2cabdc8ce016ea1a6ecac3be7 /sci-libs
parentremove unused license, sys-cluster/lam-mpi removed from the tree, re #324415 (diff)
downloadgentoo-2-96769bef6b6758fe45f70ae1e01983fe117ed59b.tar.gz
gentoo-2-96769bef6b6758fe45f70ae1e01983fe117ed59b.tar.bz2
gentoo-2-96769bef6b6758fe45f70ae1e01983fe117ed59b.zip
sci-libs/qd: Fix for test, underlinking problem, #423449
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/qd/ChangeLog7
-rw-r--r--sci-libs/qd/files/qd-2.3.12-autotools.patch3
-rw-r--r--sci-libs/qd/files/qd-2.3.13-autotools.patch15
-rw-r--r--sci-libs/qd/qd-2.3.12.ebuild23
-rw-r--r--sci-libs/qd/qd-2.3.13.ebuild20
5 files changed, 48 insertions, 20 deletions
diff --git a/sci-libs/qd/ChangeLog b/sci-libs/qd/ChangeLog
index 5e87cda86ee7..66b180ef83a1 100644
--- a/sci-libs/qd/ChangeLog
+++ b/sci-libs/qd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/qd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/ChangeLog,v 1.11 2012/04/18 23:20:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/ChangeLog,v 1.12 2012/06/25 16:53:25 jlec Exp $
+
+ 25 Jun 2012; Justin Lecher <jlec@gentoo.org> qd-2.3.12.ebuild,
+ files/qd-2.3.12-autotools.patch, qd-2.3.13.ebuild,
+ +files/qd-2.3.13-autotools.patch:
+ Fix for test, underlinking problem, #423449
*qd-2.3.13 (18 Apr 2012)
diff --git a/sci-libs/qd/files/qd-2.3.12-autotools.patch b/sci-libs/qd/files/qd-2.3.12-autotools.patch
index 1389c519712e..346ac61151a5 100644
--- a/sci-libs/qd/files/qd-2.3.12-autotools.patch
+++ b/sci-libs/qd/files/qd-2.3.12-autotools.patch
@@ -28,7 +28,7 @@ diff -Nur qd-2.3.12.orig/fortran/Makefile.am qd-2.3.12/fortran/Makefile.am
if UPCASE_MODULE
DDEXT=DDEXT.$(module_ext)
-@@ -14,17 +14,18 @@
+@@ -14,17 +14,19 @@ QDMOD=qdmodule.$(module_ext)
DDMOD=ddmodule.$(module_ext)
endif
@@ -43,6 +43,7 @@ diff -Nur qd-2.3.12.orig/fortran/Makefile.am qd-2.3.12/fortran/Makefile.am
-$(QDEXT): qdext.o
+lib_LTLIBRARIES = libqdmod.la libqd_f_main.la
+libqdmod_la_SOURCES = ddext.f ddmod.f qdext.f qdmod.f f_dd.cpp f_qd.cpp
++libqdmod_la_LIBADD = $(FCLIBS)
+libqd_f_main_la_SOURCES = main.cpp
+ddmod.lo: $(DDEXT) ddext.lo
+qdmod.lo: ddmod.lo $(DDMOD) qdext.lo
diff --git a/sci-libs/qd/files/qd-2.3.13-autotools.patch b/sci-libs/qd/files/qd-2.3.13-autotools.patch
new file mode 100644
index 000000000000..6a89cb6607b2
--- /dev/null
+++ b/sci-libs/qd/files/qd-2.3.13-autotools.patch
@@ -0,0 +1,15 @@
+ fortran/Makefile.am | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/fortran/Makefile.am b/fortran/Makefile.am
+index 1ab54f7..7889fa3 100644
+--- a/fortran/Makefile.am
++++ b/fortran/Makefile.am
+@@ -16,6 +16,7 @@ endif
+
+ lib_LTLIBRARIES = libqdmod.la libqd_f_main.la
+ libqdmod_la_SOURCES = ddext.f ddmod.f qdext.f qdmod.f f_dd.cpp f_qd.cpp
++libqdmod_la_LIBADD = $(FCLIBS)
+ libqd_f_main_la_SOURCES = main.cpp
+ ddmod.lo: $(DDEXT) ddext.lo
+ qdmod.lo: ddmod.lo $(DDMOD) qdext.lo
diff --git a/sci-libs/qd/qd-2.3.12.ebuild b/sci-libs/qd/qd-2.3.12.ebuild
index 5d669e3bc015..972be7d96fb5 100644
--- a/sci-libs/qd/qd-2.3.12.ebuild
+++ b/sci-libs/qd/qd-2.3.12.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.12.ebuild,v 1.1 2012/01/12 22:53:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.12.ebuild,v 1.2 2012/06/25 16:53:25 jlec Exp $
EAPI=4
-inherit autotools eutils fortran-2
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils fortran-2
DESCRIPTION="Quad-double and double-double float arithmetics"
HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
@@ -22,21 +24,20 @@ pkg_setup() {
use fortran && fortran-2_pkg_setup
}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-autotools.patch
- eautoreconf
-}
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-shared
$(use_enable fortran enable_fortran)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
+
use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
dosym qd_real.h /usr/include/qd/qd.h
dosym dd_real.h /usr/include/qd/dd.h
diff --git a/sci-libs/qd/qd-2.3.13.ebuild b/sci-libs/qd/qd-2.3.13.ebuild
index d4124ee9b288..e1089fc5e736 100644
--- a/sci-libs/qd/qd-2.3.13.ebuild
+++ b/sci-libs/qd/qd-2.3.13.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.13.ebuild,v 1.1 2012/04/18 23:20:28 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/qd/qd-2.3.13.ebuild,v 1.2 2012/06/25 16:53:25 jlec Exp $
EAPI=4
-inherit eutils fortran-2
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils fortran-2
DESCRIPTION="Quad-double and double-double float arithmetics"
HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
@@ -22,16 +24,20 @@ pkg_setup() {
use fortran && fortran-2_pkg_setup
}
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-shared
$(use_enable fortran enable_fortran)
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
+
use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
dosym qd_real.h /usr/include/qd/qd.h
dosym dd_real.h /usr/include/qd/dd.h