summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 21:30:40 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 21:30:40 +0000
commit96cf7018eec5d423ee3f26890aafb96d0d4c8c37 (patch)
treed898ae412f619cc88be038edd42d701514a4627e /sci-libs
parentUpdate LICENSE, the Scintilla license is a duplicate of the HPND. (diff)
downloadgentoo-2-96cf7018eec5d423ee3f26890aafb96d0d4c8c37.tar.gz
gentoo-2-96cf7018eec5d423ee3f26890aafb96d0d4c8c37.tar.bz2
gentoo-2-96cf7018eec5d423ee3f26890aafb96d0d4c8c37.zip
sci-libs/itpp: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/itpp-4.0.6.ebuild88
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild10
-rw-r--r--sci-libs/itpp/itpp-4.2-r2.ebuild10
-rw-r--r--sci-libs/itpp/metadata.xml4
5 files changed, 18 insertions, 102 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 1b3a0b8ca7e0..d502381a8db5 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/itpp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.116 2012/08/03 19:24:33 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.117 2013/02/21 21:30:40 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> -itpp-4.0.6.ebuild,
+ itpp-4.2-r1.ebuild, itpp-4.2-r2.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config
03 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> itpp-4.2-r2.ebuild:
Keyword amd64-linux x86-linux
diff --git a/sci-libs/itpp/itpp-4.0.6.ebuild b/sci-libs/itpp/itpp-4.0.6.ebuild
deleted file mode 100644
index fb4d5b5a36ec..000000000000
--- a/sci-libs/itpp/itpp-4.0.6.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.11 2012/07/06 07:45:01 jlec Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-3"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="blas debug doc fftw lapack minimal"
-
-RDEPEND="
- !minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
- blas? (
- virtual/blas
- lapack? ( virtual/lapack ) )"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- virtual/latex-base )"
-
-# we need this to prevent itpp's specialized debug lib
-# (built with USE="debug" set) from being stripped
-RESTRICT="strip"
-
-pkg_setup() {
- # lapack can only be used in conjunction with blas
- if use lapack && ! use blas; then
- die "USE=lapack requires USE=blas to be set"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc44.patch
-}
-
-src_compile() {
- # turn off performance critical debug code
- append-flags -DNDEBUG
-
- # make sure that -g is stripped always since we use
- # RESTRICT=strip. If debug info is needed please enable
- # the debug use flag and link against the debug *.so
- filter-flags -g
-
- local blas_conf="--without-blas"
- local lapack_conf="--without-lapack"
- if use blas; then
- if use lapack; then
- blas_conf="--with-blas=$(pkg-config lapack --libs)"
- lapack_conf="--with-lapack"
- else
- blas_conf="--with-blas=$(pkg-config blas --libs)"
- fi
- fi
-
- local fftw_conf="--without-fft";
- if use fftw;
- then
- fftw_conf="--with-fft=-lfftw3"
- fi
-
- local myconf="--docdir=/usr/share/doc/${P}"
- if use minimal; then
- myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
- fi
-
- econf $(use_enable doc html-doc) \
- $(use_enable debug) \
- "${blas_conf}" \
- "${lapack_conf}" \
- "${fftw_conf}" \
- ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
- ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO \
- || die "failed to install docs"
-}
diff --git a/sci-libs/itpp/itpp-4.2-r1.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index 624efcf71397..9e671220655c 100644
--- a/sci-libs/itpp/itpp-4.2-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.14 2012/07/17 08:11:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.15 2013/02/21 21:30:40 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils flag-o-matic
+inherit autotools-utils flag-o-matic toolchain-funcs
DESCRIPTION="C++ library of mathematical, signal processing and communication"
HOMEPAGE="http://itpp.sourceforge.net/"
@@ -43,9 +43,9 @@ src_prepare() {
src_configure() {
local blasconf="no"
- use blas && blasconf="$(pkg-config --libs blas)"
+ use blas && blasconf="$($(tc-getPKG_CONFIG) --libs blas)"
local lapackconf="no"
- use lapack && lapackconf="$(pkg-config --libs blas lapack)"
+ use lapack && lapackconf="$($(tc-getPKG_CONFIG) --libs blas lapack)"
local myeconfargs=(
--docdir="${EPREFIX}/usr/share/doc/${PF}"
diff --git a/sci-libs/itpp/itpp-4.2-r2.ebuild b/sci-libs/itpp/itpp-4.2-r2.ebuild
index f7d283973167..ca322e542aba 100644
--- a/sci-libs/itpp/itpp-4.2-r2.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r2.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r2.ebuild,v 1.3 2012/08/03 19:24:33 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r2.ebuild,v 1.4 2013/02/21 21:30:40 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
-inherit autotools-utils flag-o-matic
+inherit autotools-utils flag-o-matic toolchain-funcs
DESCRIPTION="C++ library of mathematical, signal processing and communication"
HOMEPAGE="http://itpp.sourceforge.net/"
@@ -46,9 +46,9 @@ src_prepare() {
src_configure() {
local blasconf="no"
- use blas && blasconf="$(pkg-config --libs blas)"
+ use blas && blasconf="$($(tc-getPKG_CONFIG) --libs blas)"
local lapackconf="no"
- use lapack && lapackconf="$(pkg-config --libs blas lapack)"
+ use lapack && lapackconf="$($(tc-getPKG_CONFIG) --libs blas lapack)"
local myeconfargs=(
--docdir="${EPREFIX}/usr/share/doc/${PF}"
diff --git a/sci-libs/itpp/metadata.xml b/sci-libs/itpp/metadata.xml
index 44d71c60f368..8d93511d9b03 100644
--- a/sci-libs/itpp/metadata.xml
+++ b/sci-libs/itpp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
IT++ is a C++ library of mathematical, signal processing and
communication classes and functions. Its main use is in simulation
of communication systems and for performing research in the area of