summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 10:39:51 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 10:39:51 +0000
commitdd0dd22eb9458fd19a548634dfe7c9104485b855 (patch)
treecefd1f5be509117d9dd6297fc7b89a07be4f3496 /sci-libs
parentdrop empty *DEPEND (diff)
downloadgentoo-2-dd0dd22eb9458fd19a548634dfe7c9104485b855.tar.gz
gentoo-2-dd0dd22eb9458fd19a548634dfe7c9104485b855.tar.bz2
gentoo-2-dd0dd22eb9458fd19a548634dfe7c9104485b855.zip
Move preparations to src_prepare
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/coinor-os/ChangeLog5
-rw-r--r--sci-libs/coinor-os/coinor-os-2.8.3.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/sci-libs/coinor-os/ChangeLog b/sci-libs/coinor-os/ChangeLog
index f6ae88ed4e3f..66c937cb6877 100644
--- a/sci-libs/coinor-os/ChangeLog
+++ b/sci-libs/coinor-os/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/coinor-os
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-os/ChangeLog,v 1.2 2014/02/04 09:39:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-os/ChangeLog,v 1.3 2014/02/04 10:39:51 jlec Exp $
+
+ 04 Feb 2014; Justin Lecher <jlec@gentoo.org> coinor-os-2.8.3.ebuild:
+ Move preparations to src_prepare
04 Feb 2014; Justin Lecher <jlec@gentoo.org> coinor-os-2.8.3.ebuild:
Fix the common coinor pkg-config installation problem
diff --git a/sci-libs/coinor-os/coinor-os-2.8.3.ebuild b/sci-libs/coinor-os/coinor-os-2.8.3.ebuild
index fdcdb152f40d..e729cc02edbe 100644
--- a/sci-libs/coinor-os/coinor-os-2.8.3.ebuild
+++ b/sci-libs/coinor-os/coinor-os-2.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-os/coinor-os-2.8.3.ebuild,v 1.2 2014/02/04 09:39:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-os/coinor-os-2.8.3.ebuild,v 1.3 2014/02/04 10:39:51 jlec Exp $
EAPI=5
@@ -35,15 +35,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
src_prepare() {
+ append-cppflags -DNDEBUG
+ # needed for the --with-coin-instdir
+ dodir /usr
sed -i \
-e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
configure || die
autotools-utils_src_prepare
}
+
src_configure() {
- append-cppflags -DNDEBUG
- # needed for the --with-coin-instdir
- dodir /usr
local myeconfargs=(
--enable-dependency-linking
--with-coin-instdir="${ED}"/usr