summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-04 17:03:23 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-04 17:03:23 +0000
commitf907bbd4e89e5d8a5b6437bea5d773537514f642 (patch)
tree9d6a233369cdff1a077b4f69bafd6ded30aca0bb /sci-libs
parentVersion bump. (diff)
downloadgentoo-2-f907bbd4e89e5d8a5b6437bea5d773537514f642.tar.gz
gentoo-2-f907bbd4e89e5d8a5b6437bea5d773537514f642.tar.bz2
gentoo-2-f907bbd4e89e5d8a5b6437bea5d773537514f642.zip
Version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog10
-rw-r--r--sci-libs/geos/files/digest-geos-3.0.03
-rw-r--r--sci-libs/geos/geos-2.2.3.ebuild83
-rw-r--r--sci-libs/geos/geos-3.0.0.ebuild50
-rw-r--r--sci-libs/geos/metadata.xml13
5 files changed, 113 insertions, 46 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index 87657dfa8755..648367805265 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/geos
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.24 2007/04/16 07:59:15 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.25 2008/01/04 17:03:22 bicatali Exp $
+
+*geos-3.0.0 (04 Jan 2008)
+
+ 04 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ geos-2.2.3.ebuild, +geos-3.0.0.ebuild:
+ Version bump. Closing bug #184391
16 Apr 2007; Markus Rothe <corsair@gentoo.org> geos-2.2.3.ebuild:
Stable on ppc64
diff --git a/sci-libs/geos/files/digest-geos-3.0.0 b/sci-libs/geos/files/digest-geos-3.0.0
new file mode 100644
index 000000000000..bbc583df651f
--- /dev/null
+++ b/sci-libs/geos/files/digest-geos-3.0.0
@@ -0,0 +1,3 @@
+MD5 3f7940abee9fec69a9787878cd3ae771 geos-3.0.0.tar.bz2 1091475
+RMD160 195fb24de2f67d515f629f1dcb3dccec7711bdac geos-3.0.0.tar.bz2 1091475
+SHA256 baa86c5125a349504e3890312e68ab3bf3601489cefe9ceb9f659e34bbe5eb4f geos-3.0.0.tar.bz2 1091475
diff --git a/sci-libs/geos/geos-2.2.3.ebuild b/sci-libs/geos/geos-2.2.3.ebuild
index 1ae92dfa4fa3..5e3a0ab9e18d 100644
--- a/sci-libs/geos/geos-2.2.3.ebuild
+++ b/sci-libs/geos/geos-2.2.3.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.2.3.ebuild,v 1.3 2007/04/16 07:59:15 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.2.3.ebuild,v 1.4 2008/01/04 17:03:22 bicatali Exp $
USE_RUBY="ruby18"
RUBY_OPTIONAL="yes"
inherit eutils distutils ruby toolchain-funcs
-DESCRIPTION="Geometry Engine - Open Source"
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
HOMEPAGE="http://geos.refractions.net"
SRC_URI="http://geos.refractions.net/${P}.tar.bz2"
@@ -30,38 +30,37 @@ src_unpack() {
}
src_compile() {
- econf --with-pic --enable-static || die "econf failed"
+ econf || die "econf failed"
emake || die "emake failed"
if use python; then
- einfo "Compilling PyGEOS"
- cd "${S}/swig/python"
- cp "${FILESDIR}/python.i" "${S}/swig/python/"
- rm -f geos_wrap.cxx
- swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
- distutils_src_compile
+ einfo "Compilling PyGEOS"
+ cd "${S}/swig/python"
+ cp "${FILESDIR}/python.i" "${S}/swig/python/"
+ rm -f geos_wrap.cxx
+ swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
+ distutils_src_compile
fi
if use ruby; then
- einfo "Compilling Ruby bindings"
- cd "${S}/swig/ruby"
- swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
- local CXX=$(tc-getCXX)
- local RUBY_ARCHDIR="$(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')"
- ${CXX} ${CXXFLAGS} -I../../source/headers -I${RUBY_ARCHDIR} \
+ einfo "Compilling Ruby bindings"
+ cd "${S}"/swig/ruby
+ swig -c++ -ruby -autorename -o geos_wrap.cxx ../geos.i
+ local CXX=$(tc-getCXX)
+ local RUBY_ARCHDIR="$(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]')"
+ ${CXX} ${CXXFLAGS} -I../../source/headers -I${RUBY_ARCHDIR} \
-fPIC -c geos_wrap.cxx
- ${CXX} ${CXXFLAGS} -shared -L${S}/source/geom/.libs -lgeos \
+ ${CXX} ${CXXFLAGS} -shared -L"${S}"/source/geom/.libs -lgeos \
-lruby geos_wrap.o -o geos.so
fi
}
src_test() {
- cd "${S}"
emake check || die "Trying make check without success."
# I think this test must be made after the PyGEOS installation
#export PYTHONPATH=${S}/swig/python
if use python; then
- cd ${S}/swig/python
- python tests/runtests.py -v
+ cd "${S}"/swig/python
+ python tests/runtests.py -v
fi
}
@@ -69,39 +68,39 @@ src_install(){
emake install DESTDIR="${D}" || die "emake install failed"
if use python; then
- einfo "Installing PyGEOS"
- cd ${S}/swig/python
- distutils_src_install
- insinto /usr/share/doc/${PF}/python
- doins README.txt tests/*.py
- insinto /usr/share/doc/${PF}/python/cases
- doins tests/cases/*
+ einfo "Installing PyGEOS"
+ cd "${S}"/swig/python
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/python
+ doins README.txt tests/*.py || die
+ insinto /usr/share/doc/${PF}/python/cases
+ doins tests/cases/* || die
fi
if use ruby; then
- local RUBY_SITEARCHDIR="$(ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]')"
- einfo "Installing Ruby bindings in ${RUBY_SITEARCHDIR}/${PN}"
- cd ${S}/swig/ruby
- insinto ${RUBY_SITEARCHDIR}/${PN}
- doins geos.so
- insinto /usr/share/doc/${PF}/ruby
- doins README.txt test/*.rb
- if use doc; then
- erubydoc
- fi
+ local RUBY_SITEARCHDIR="$(ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]')"
+ einfo "Installing Ruby bindings in ${RUBY_SITEARCHDIR}/${PN}"
+ cd "${S}"/swig/ruby
+ insinto ${RUBY_SITEARCHDIR}/${PN}
+ doins geos.so || die
+ insinto /usr/share/doc/${PF}/ruby
+ doins README.txt test/*.rb || die
+ if use doc; then
+ erubydoc
+ fi
fi
if use doc; then
- cd ${S}/doc
- make doxygen-html
- dohtml -r doxygen_docs/html/*
+ cd "${S}"/doc
+ emake doxygen-html || die "make doxygen docs failed"
+ dohtml -r doxygen_docs/html/* || die
fi
cd "${S}"
- dodoc AUTHORS NEWS README TODO
+ dodoc AUTHORS NEWS README TODO || die
}
pkg_postinst() {
if use python; then
python_version
- python_mod_optimize ${ROOT}usr/bin
+ python_mod_optimize "${ROOT}"usr/bin
fi
}
diff --git a/sci-libs/geos/geos-3.0.0.ebuild b/sci-libs/geos/geos-3.0.0.ebuild
new file mode 100644
index 000000000000..c6b22bd1115c
--- /dev/null
+++ b/sci-libs/geos/geos-3.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.0.0.ebuild,v 1.1 2008/01/04 17:03:22 bicatali Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_/}
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://geos.refractions.net/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )\
+ ruby? ( >=dev-lang/swig-1.3.29 )
+ python? ( >=dev-lang/swig-1.3.29 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf
+
+ if ! use python && ! use ruby ; then
+ myconf="--disable-swig"
+ fi
+
+ econf ${myconf} \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO || die
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ dohtml -r doxygen_docs/html/*
+ fi
+}
diff --git a/sci-libs/geos/metadata.xml b/sci-libs/geos/metadata.xml
index 7b826278ad91..c39dbd31f58e 100644
--- a/sci-libs/geos/metadata.xml
+++ b/sci-libs/geos/metadata.xml
@@ -1,6 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-geosciences</herd>
- <herd>postgresql</herd>
+ <herd>sci-geosciences</herd>
+ <herd>postgresql</herd>
+ <longdescription lang="en">
+ Geometric Engine Open Source provides a spatial object model and
+ fundamental geometric functions. It implements the geometry model
+ defined in the OpenGIS Consortium Simple Features Specification for
+ SQL. Functions provided include: spatial predicates (based on the
+ DE-9IM model), overlay functions (intersection, difference, union,
+ symmetric difference), buffer, convex hull, area and distance
+ functions, and topological validity checking.
+ </longdescription>
</pkgmetadata>