summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-14 19:53:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-14 19:53:51 +0000
commita11463f6162470de6fe9b840c237c649b752ea51 (patch)
tree3e02d96e5e5f8ff198d468ad935a85d4885b8bd0 /sci-mathematics/agda/agda-1.0.2-r2.ebuild
parentStable on alpha, bug #327379 (diff)
downloadgentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.tar.gz
gentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.tar.bz2
gentoo-2-a11463f6162470de6fe9b840c237c649b752ea51.zip
Version bump, ebuild originally from markusle (bug #303973). Also forced emacs on dependencies (thanks to ulm, bug #336741)
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/agda/agda-1.0.2-r2.ebuild')
-rw-r--r--sci-mathematics/agda/agda-1.0.2-r2.ebuild33
1 files changed, 13 insertions, 20 deletions
diff --git a/sci-mathematics/agda/agda-1.0.2-r2.ebuild b/sci-mathematics/agda/agda-1.0.2-r2.ebuild
index 5f9d6b6b2dd3..698bf5b369e2 100644
--- a/sci-mathematics/agda/agda-1.0.2-r2.ebuild
+++ b/sci-mathematics/agda/agda-1.0.2-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r2.ebuild,v 1.1 2008/12/05 16:58:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r2.ebuild,v 1.2 2010/09/14 19:53:51 bicatali Exp $
+EAPI=2
inherit elisp-common eutils
MY_PN="Agda"
@@ -14,48 +15,40 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="emacs"
+IUSE=""
-RDEPEND="emacs? ( virtual/emacs app-emacs/haskell-mode )"
+RDEPEND="virtual/emacs
+ app-emacs/haskell-mode"
DEPEND="${RDEPEND}
dev-lang/ghc
dev-haskell/mtl"
SITEFILE="50${PN}-gentoo.el"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-make_install.patch
epatch "${FILESDIR}"/${P}-upstream-fixes.patch
-
sed -e "s:-package lang::" -i src/Makefile.in \
|| die "Failed to fix Makfile.in"
}
-src_compile() {
+src_configure() {
econf --enable-newsyntax
- emake || die "emake failed"
- #if use doc ; then
- # emake html
- #fi
}
src_install() {
- emake -C src ROOT="${D}" install || die "make install failed"
+ emake -C src ROOT="${D}" install || die "emake install failed"
dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
dosym emacsagda /usr/bin/agda
- if use emacs; then
- elisp-install ${PN} elisp/agda-mode.el || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
+ elisp-install ${PN} elisp/agda-mode.el || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
}
pkg_postinst() {
- use emacs && elisp-site-regen
+ elisp-site-regen
}
pkg_postrm() {
- use emacs && elisp-site-regen
+ elisp-site-regen
}