summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-09-23 12:12:05 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-09-23 12:12:05 +0000
commit6c7b37457661439ec25d973e8a24ff8bd356ba05 (patch)
tree6d0b1974b34689ecb0a922dfc1ff8b403c0cba33 /sci-mathematics/agda
parentstable x86, bug 193501 (diff)
downloadgentoo-2-6c7b37457661439ec25d973e8a24ff8bd356ba05.tar.gz
gentoo-2-6c7b37457661439ec25d973e8a24ff8bd356ba05.tar.bz2
gentoo-2-6c7b37457661439ec25d973e8a24ff8bd356ba05.zip
add elisp-site-regen to postrm and canonicalise it in postinst; depending on USE=emacs
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog9
-rw-r--r--sci-mathematics/agda/agda-1.0.2-r1.ebuild60
-rw-r--r--sci-mathematics/agda/files/digest-agda-1.0.2-r13
3 files changed, 71 insertions, 1 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 50dfe3dde1d8..97cc3f403ee6 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.4 2007/07/31 21:55:39 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.5 2007/09/23 12:12:04 opfer Exp $
+
+*agda-1.0.2-r1 (23 Sep 2007)
+
+ 23 Sep 2007; Christian Faulhammer <opfer@gentoo.org>
+ +agda-1.0.2-r1.ebuild:
+ add elisp-site-regen to postrm and canonicalise it in postinst; depending on
+ USE=emacs
31 Jul 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Reassigning to sci from math-proof.
diff --git a/sci-mathematics/agda/agda-1.0.2-r1.ebuild b/sci-mathematics/agda/agda-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..9f517c272c17
--- /dev/null
+++ b/sci-mathematics/agda/agda-1.0.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r1.ebuild,v 1.1 2007/09/23 12:12:04 opfer Exp $
+
+inherit autotools elisp-common
+
+MY_PN="Agda"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DESCRIPTION="Agda is a proof assistant in Haskell."
+HOMEPAGE="http://unit.aist.go.jp/cvs/Agda/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc emacs"
+
+DEPEND="virtual/ghc
+ emacs? ( virtual/emacs )
+ doc? ( dev-haskell/haddock )"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/agda-make_install.patch"
+}
+
+src_compile() {
+ cd "${S}"
+ econf --enable-newsyntax || die "./configure failed"
+ emake || die "make failed"
+ if use doc ; then
+ emake html
+ fi
+}
+
+src_install() {
+ if use emacs; then
+ cd "${S}/elisp"
+ elisp-install ${PN} *.el
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+ cd "${S}/src"
+ make prefix="${D}/usr" install || die "make install failed"
+ dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
+ dosym /usr/bin/emacsagda /usr/bin/agda
+
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/sci-mathematics/agda/files/digest-agda-1.0.2-r1 b/sci-mathematics/agda/files/digest-agda-1.0.2-r1
new file mode 100644
index 000000000000..6fe07da53bc6
--- /dev/null
+++ b/sci-mathematics/agda/files/digest-agda-1.0.2-r1
@@ -0,0 +1,3 @@
+MD5 68f669d2b98d12999aabeab6253f4c35 Agda-1.0.2.tar.gz 505642
+RMD160 6686a0bd5920a83a3e08ef2894b8ddf1620f21c2 Agda-1.0.2.tar.gz 505642
+SHA256 2ab56783a26e84f64422316daf0ce160f983667357361e2986baa13fb17e7ea1 Agda-1.0.2.tar.gz 505642