summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-04 06:27:07 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-04 06:27:07 +0000
commit9ca3c7fee962fab47096692b7839866ea93360c5 (patch)
treeda5f3c62833baeba493767082c2c1ac208d945a1 /sci-mathematics/frobby
parentAdded patch to 5.5 version so it mounts shares again (bug #424487). (diff)
downloadgentoo-2-9ca3c7fee962fab47096692b7839866ea93360c5.tar.gz
gentoo-2-9ca3c7fee962fab47096692b7839866ea93360c5.tar.bz2
gentoo-2-9ca3c7fee962fab47096692b7839866ea93360c5.zip
sci-mathematics/frobby: Fix for build with gcc-4.7, #424663; handle static-libs
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/frobby')
-rw-r--r--sci-mathematics/frobby/ChangeLog6
-rw-r--r--sci-mathematics/frobby/files/frobby-gcc-4.7.patch32
-rw-r--r--sci-mathematics/frobby/frobby-0.9.0.ebuild26
-rw-r--r--sci-mathematics/frobby/metadata.xml12
4 files changed, 56 insertions, 20 deletions
diff --git a/sci-mathematics/frobby/ChangeLog b/sci-mathematics/frobby/ChangeLog
index 900c103a2e72..f217191fc871 100644
--- a/sci-mathematics/frobby/ChangeLog
+++ b/sci-mathematics/frobby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/frobby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.11 2012/05/18 16:32:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/ChangeLog,v 1.12 2012/07/04 06:27:07 jlec Exp $
+
+ 04 Jul 2012; Justin Lecher <jlec@gentoo.org> frobby-0.9.0.ebuild,
+ +files/frobby-gcc-4.7.patch, metadata.xml:
+ Fix for build with gcc-4.7, #424663; handle static-libs
18 May 2012; Thomas Kahle <tomka@gentoo.org> -files/frobby-latex.patch,
-files/frobby-useless-checks.patch, -frobby-0.8.2-r1.ebuild,
diff --git a/sci-mathematics/frobby/files/frobby-gcc-4.7.patch b/sci-mathematics/frobby/files/frobby-gcc-4.7.patch
new file mode 100644
index 000000000000..4a73161166d9
--- /dev/null
+++ b/sci-mathematics/frobby/files/frobby-gcc-4.7.patch
@@ -0,0 +1,32 @@
+ src/main.cpp | 3 +++
+ src/randomDataGenerators.cpp | 3 +++
+ 2 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/src/main.cpp b/src/main.cpp
+index a16754e..315ea53 100755
+--- a/src/main.cpp
++++ b/src/main.cpp
+@@ -25,6 +25,9 @@
+ #include <ctime>
+ #include <cstdlib>
+
++#include <sys/types.h>
++#include <unistd.h>
++
+ /** This function runs the Frobby console interface. the ::main
+ function calls this function after having set up DEBUG-specific
+ things, catching exceptions, setting the random seed and so on.
+diff --git a/src/randomDataGenerators.cpp b/src/randomDataGenerators.cpp
+index 432a90a..1de3559 100755
+--- a/src/randomDataGenerators.cpp
++++ b/src/randomDataGenerators.cpp
+@@ -26,6 +26,9 @@
+ #include <limits>
+ #include <ctime>
+
++#include <sys/types.h>
++#include <unistd.h>
++
+ void generateLinkedListIdeal(BigIdeal& ideal, size_t variableCount) {
+ VarNames names(variableCount);
+ ideal.clearAndSetNames(variableCount);
diff --git a/sci-mathematics/frobby/frobby-0.9.0.ebuild b/sci-mathematics/frobby/frobby-0.9.0.ebuild
index dffd4e08483f..6b5a3de9e43e 100644
--- a/sci-mathematics/frobby/frobby-0.9.0.ebuild
+++ b/sci-mathematics/frobby/frobby-0.9.0.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.4 2012/05/18 16:32:13 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/frobby/frobby-0.9.0.ebuild,v 1.5 2012/07/04 06:27:07 jlec Exp $
EAPI=4
inherit eutils
-DESCRIPTION="Frobby is a software system and project for computations with monomial ideals"
+DESCRIPTION="Software system and project for computations with monomial ideals"
HOMEPAGE="http://www.broune.com/frobby/"
SRC_URI="http://www.broune.com/frobby/frobby_v${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND="dev-libs/gmp[cxx]"
DEPEND="${RDEPEND}
@@ -22,9 +22,11 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/frobby_v${PV}"
src_prepare() {
- epatch "${FILESDIR}/${PN}-cflags-no-strip.patch"
+ epatch \
+ "${FILESDIR}/${PN}-cflags-no-strip.patch" \
+ "${FILESDIR}/${PN}-gcc-4.7.patch"
# CXXFLAGS are called CPPFLAGS
- sed "s/CPPFLAGS/CXXFLAGS/" -i Makefile
+ sed "s/CPPFLAGS/CXXFLAGS/" -i Makefile || die
}
src_compile() {
@@ -32,20 +34,18 @@ src_compile() {
# breaking cross-compile.
CXX=$(tc-getCXX) emake
CXX=$(tc-getCXX) emake library
- if use doc; then
- emake docPdf
- fi
+ use doc && emake docPdf
}
src_install() {
dobin bin/frobby
- dolib.a bin/libfrobby.a
+ use static-libs && dolib.a bin/libfrobby.a
+
insinto /usr/include
doins src/frobby.h
- dodir /usr/include/"${PN}"
+
insinto /usr/include/"${PN}"
doins src/stdinc.h
- if use doc; then
- dodoc bin/manual.pdf
- fi
+
+ use doc && dodoc bin/manual.pdf
}
diff --git a/sci-mathematics/frobby/metadata.xml b/sci-mathematics/frobby/metadata.xml
index 06fa79d6bbc5..4e93bbb7622c 100644
--- a/sci-mathematics/frobby/metadata.xml
+++ b/sci-mathematics/frobby/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>tomka@gentoo.org</email>
- <name>Thomas Kahle</name>
-</maintainer>
-<herd>sci</herd>
-<longdescription lang="en">
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sci</herd>
+ <longdescription lang="en">
Frobby is a software system and library for computations with monomial ideals.
</longdescription>
</pkgmetadata>