summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2012-11-30 17:34:03 +0000
committerAndrey Grozin <grozin@gentoo.org>2012-11-30 17:34:03 +0000
commit4a62f73d98e314d50dd28228f47b4af2aecd2e94 (patch)
tree3b4b5697c90be426ea34edac01faeb5b21b96478 /sci-mathematics/gsl-shell
parentFix as-needed patch for newer autoconf (diff)
downloadgentoo-2-4a62f73d98e314d50dd28228f47b4af2aecd2e94.tar.gz
gentoo-2-4a62f73d98e314d50dd28228f47b4af2aecd2e94.tar.bz2
gentoo-2-4a62f73d98e314d50dd28228f47b4af2aecd2e94.zip
Version bump
(Portage version: 2.2.0_alpha142/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/gsl-shell')
-rw-r--r--sci-mathematics/gsl-shell/ChangeLog8
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-font.patch17
-rw-r--r--sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild (renamed from sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild)11
3 files changed, 19 insertions, 17 deletions
diff --git a/sci-mathematics/gsl-shell/ChangeLog b/sci-mathematics/gsl-shell/ChangeLog
index d72e6f5dc2d5..183dec97e462 100644
--- a/sci-mathematics/gsl-shell/ChangeLog
+++ b/sci-mathematics/gsl-shell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gsl-shell
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.5 2012/09/26 14:50:50 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/ChangeLog,v 1.6 2012/11/30 17:34:03 grozin Exp $
+
+*gsl-shell-2.2.0 (30 Nov 2012)
+
+ 30 Nov 2012; Andrey Grozin <grozin@gentoo.org> -gsl-shell-2.2.0_beta1.ebuild,
+ +gsl-shell-2.2.0.ebuild, files/gsl-shell-font.patch:
+ Version bump
26 Sep 2012; Andrey Grozin <grozin@gentoo.org> gsl-shell-2.2.0_beta1.ebuild:
Fixing a stupid typo
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-font.patch b/sci-mathematics/gsl-shell/files/gsl-shell-font.patch
index 0511b26b8af8..d8879497c4cd 100644
--- a/sci-mathematics/gsl-shell/files/gsl-shell-font.patch
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-font.patch
@@ -1,13 +1,10 @@
diff -r -U1 gsl-shell.orig/agg-plot/support_x11.cpp gsl-shell/agg-plot/support_x11.cpp
---- gsl-shell.orig/agg-plot/support_x11.cpp 2012-09-12 01:13:31.000000000 +0700
-+++ gsl-shell/agg-plot/support_x11.cpp 2012-09-26 16:07:10.000000000 +0700
-@@ -4,3 +4,3 @@
-
+--- gsl-shell.orig/agg-plot/support_x11.cpp 2012-11-27 04:55:38.000000000 +0700
++++ gsl-shell/agg-plot/support_x11.cpp 2012-11-30 23:02:31.000000000 +0700
+@@ -9,4 +9,4 @@
+ #else
-const char *ttf_names[] = {"ubuntu-font-family/Ubuntu-R.ttf", "freefont/FreeSans.ttf", "ttf-dejavu/DejaVuSans.ttf", 0};
+-#define TTF_SYSTEM_DIR "/usr/share/fonts/truetype/"
+const char *ttf_names[] = {"ubuntu-font-family/Ubuntu-R.ttf", "freefont-ttf/FreeSans.ttf", "dejavu/DejaVuSans.ttf", 0};
-
-@@ -8,3 +8,3 @@
- {
-- const char* ttf_dir = "/usr/share/fonts/truetype/";
-+ const char* ttf_dir = "/usr/share/fonts/";
- unsigned len = strlen(ttf_dir);
++#define TTF_SYSTEM_DIR "/usr/share/fonts/"
+ #define CONSOLE_FONT_NAME "monospace"
diff --git a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
index 5c950e666049..4896cf682781 100644
--- a/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild
+++ b/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0_beta1.ebuild,v 1.5 2012/09/26 14:50:50 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gsl-shell/gsl-shell-2.2.0.ebuild,v 1.1 2012/11/30 17:34:03 grozin Exp $
EAPI=4
-inherit eutils versionator
+inherit eutils
DESCRIPTION="Lua interactive shell for sci-libs/gsl"
HOMEPAGE="http://www.nongnu.org/gsl-shell/"
-MY_P=$(version_format_string '${PN}-$1.$2.$3-$4')
-SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${MY_P}.tar.gz"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc fox"
DEPEND=">=sci-libs/gsl-1.14
@@ -24,7 +23,7 @@ DEPEND=">=sci-libs/gsl-1.14
fox? ( x11-libs/fox:1.6 )"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
+S="${WORKDIR}"/${PN}
src_prepare() {
epatch "${FILESDIR}"/${PN}-font.patch "${FILESDIR}"/${PN}-strip.patch "${FILESDIR}"/${PN}-usr.patch