summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-09-23 00:43:20 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-09-23 00:43:20 +0000
commit0e507c9dd19dddd912195a9093b8412f1cbe82e9 (patch)
tree64225261a5aad8114494f452e702127a59e1cac9 /sci-mathematics/mathomatic
parentAdding ~amd64 (diff)
downloadgentoo-2-0e507c9dd19dddd912195a9093b8412f1cbe82e9.tar.gz
gentoo-2-0e507c9dd19dddd912195a9093b8412f1cbe82e9.tar.bz2
gentoo-2-0e507c9dd19dddd912195a9093b8412f1cbe82e9.zip
Version bump, now installing files in ebuild due to broken makefile.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/Manifest12
-rw-r--r--sci-mathematics/mathomatic/files/digest-mathomatic-12.4.111
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.4.11.ebuild39
4 files changed, 49 insertions, 11 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 45522cac09ee..b7b2b00e0b9f 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.7 2005/08/28 00:58:11 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.8 2005/09/23 00:43:20 cryos Exp $
+
+*mathomatic-12.4.11 (23 Sep 2005)
+
+ 23 Sep 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +mathomatic-12.4.11.ebuild:
+ Version bump, now installing files in ebuild due to broken makefile.
28 Aug 2005; Marcus D. Hanwell <cryos@gentoo.org>
-mathomatic-12.3.1.ebuild, mathomatic-12.4.5.ebuild:
diff --git a/sci-mathematics/mathomatic/Manifest b/sci-mathematics/mathomatic/Manifest
index 268cec3fe9e2..b8e9ddfc0a0f 100644
--- a/sci-mathematics/mathomatic/Manifest
+++ b/sci-mathematics/mathomatic/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 f38bccf593e0f1fb97f5b13047bdd99e mathomatic-12.4.5.ebuild 942
+MD5 6d02de22ca2a740637f5cdbeecb748cb mathomatic-12.4.11.ebuild 939
MD5 743f0cc2ef39e607456da279e1f097a7 ChangeLog 1995
MD5 ee7955cc2715e3bac994bb045163c8b1 metadata.xml 479
MD5 32a964754f69321292b8d2b29b2d89c0 files/digest-mathomatic-12.4.5 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFDEQwwntT9W3vfTuoRAhP9AKCNOwCWguZSZHqoGHzCnI8l7tUnJQCeKiVZ
-ibDeCIp6iIR7IkKb/X+iSdc=
-=1lF5
------END PGP SIGNATURE-----
+MD5 bf6afb923996c68d8e305c5a2124a6e5 files/digest-mathomatic-12.4.11 67
diff --git a/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11 b/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11
new file mode 100644
index 000000000000..8ca71befb3f3
--- /dev/null
+++ b/sci-mathematics/mathomatic/files/digest-mathomatic-12.4.11
@@ -0,0 +1 @@
+MD5 ee54e976e1a99f8e08fa6c4a4e7924ad mathomatic-12.4.11.tgz 128156
diff --git a/sci-mathematics/mathomatic/mathomatic-12.4.11.ebuild b/sci-mathematics/mathomatic/mathomatic-12.4.11.ebuild
new file mode 100644
index 000000000000..efe2f1b91210
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.4.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.4.11.ebuild,v 1.1 2005/09/23 00:43:20 cryos Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc icc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses
+ icc? ( dev-lang/icc )"
+
+src_compile() {
+ if use icc; then
+ CC="icc" CFLAGS="-O3 -axKWNBP -ipo" LDFLAGS="-O3 -axKWNBP -ipo -limf" emake || die "emake failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic
+ dodoc changes.txt README.txt
+ doman doc/mathomatic.1
+
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/*.in
+ fi
+}