summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-12-28 18:03:11 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-12-28 18:03:11 +0000
commitaa8f73a8e57300589e3b660297b39be484d71b04 (patch)
tree5630ea55dba6f697360bd59982ebfc5e09039bfb /sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
parentMarked ppc stable. (Manifest recommit) (diff)
downloadgentoo-2-aa8f73a8e57300589e3b660297b39be484d71b04.tar.gz
gentoo-2-aa8f73a8e57300589e3b660297b39be484d71b04.tar.bz2
gentoo-2-aa8f73a8e57300589e3b660297b39be484d71b04.zip
do NOT use awk in global scope. Use bash expressions or versionator.eclass. I have switched to versionator.eclass for simplicity here.
Diffstat (limited to 'sci-mathematics/mupad/mupad-2.5.2-r2.ebuild')
-rw-r--r--sci-mathematics/mupad/mupad-2.5.2-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild b/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
index 191074844ffb..8f2dff2098d6 100644
--- a/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
+++ b/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild,v 1.1 2004/12/28 14:43:46 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mupad/mupad-2.5.2-r2.ebuild,v 1.2 2004/12/28 18:03:11 seemant Exp $
-VER=`echo $PV|awk -F. '{ print $1$2$3 }'`
+inherit versionator
+
+VER=$(replace_all_version_separators '')
URLPATH="ftp://ftp.mupad.de/MuPAD/distrib/unix/"
INSTDIR="/usr/lib/mupad"
INSTBINDIR="${INSTDIR}/share/bin"