summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-06 18:40:20 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-06 18:40:20 +0000
commitfe6ed83e06e13444e1c4e2d6549fb6cffbfa778f (patch)
treeb29400885ad52782cbc5aeeee3d2f3a065db2e54 /sci-mathematics/octave
parentAdd gpe-utils/gpe-plucker (diff)
downloadgentoo-2-fe6ed83e06e13444e1c4e2d6549fb6cffbfa778f.tar.gz
gentoo-2-fe6ed83e06e13444e1c4e2d6549fb6cffbfa778f.tar.bz2
gentoo-2-fe6ed83e06e13444e1c4e2d6549fb6cffbfa778f.zip
Added a possibility to view results of tests (bug #303537), fixed imread (bug #307693), removed hdf5 (bug #299876), and now respect LDFLAGS
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog10
-rw-r--r--sci-mathematics/octave/files/octave-3.2.4-imread.patch29
-rw-r--r--sci-mathematics/octave/files/octave-3.2.4-ldflags.patch15
-rw-r--r--sci-mathematics/octave/octave-3.2.4-r1.ebuild109
4 files changed, 162 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 7f1082c93957..27bdc00b4439 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.84 2010/02/17 04:38:38 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.85 2010/03/06 18:40:19 bicatali Exp $
+
+*octave-3.2.4-r1 (06 Mar 2010)
+
+ 06 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +octave-3.2.4-r1.ebuild, +files/octave-3.2.4-imread.patch,
+ +files/octave-3.2.4-ldflags.patch:
+ Added a possibility to view results of tests (bug #303537), fixed imread
+ (bug #307693), removed hdf5 (bug #299876), and now respect LDFLAGS
17 Feb 2010; Sébastien Fabbro <bicatali@gentoo.org> octave-3.2.4.ebuild:
Modified fltk automagic to no instead of empty string
diff --git a/sci-mathematics/octave/files/octave-3.2.4-imread.patch b/sci-mathematics/octave/files/octave-3.2.4-imread.patch
new file mode 100644
index 000000000000..4a7b73ea0ed8
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.4-imread.patch
@@ -0,0 +1,29 @@
+--- src/DLD-FUNCTIONS/__magick_read__.cc.orig 2010-03-06 08:05:25.000000000 +0000
++++ src/DLD-FUNCTIONS/__magick_read__.cc 2009-08-25 09:26:01.000000000 +0100
+@@ -30,6 +30,7 @@
+ #include "defun-dld.h"
+ #include "error.h"
+ #include "ov-struct.h"
++#include "oct-env.h"
+
+ #ifdef HAVE_MAGICK
+
+@@ -359,6 +358,18 @@
+
+ #ifdef HAVE_MAGICK
+
++ static bool initialized = false;
++
++ if (! initialized)
++ {
++ std::string program_name = octave_env::get_program_invocation_name ();
++
++ Magick::InitializeMagick (program_name.c_str ());
++
++ initialized = true;
++ }
++
++
+ if (args.length () > 2 || args.length () < 1 || ! args(0).is_string ()
+ || nargout > 3)
+ {
diff --git a/sci-mathematics/octave/files/octave-3.2.4-ldflags.patch b/sci-mathematics/octave/files/octave-3.2.4-ldflags.patch
new file mode 100644
index 000000000000..291914c6124e
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.2.4-ldflags.patch
@@ -0,0 +1,15 @@
+--- Makeconf.in.orig 2010-03-06 09:02:46.000000000 +0000
++++ Makeconf.in 2010-03-06 09:23:06.000000000 +0000
+@@ -209,10 +209,10 @@
+ BUILD_LDFLAGS = @BUILD_LDFLAGS@
+
+ SH_LD = @SH_LD@
+-SH_LDFLAGS = @SH_LDFLAGS@
++SH_LDFLAGS = @SH_LDFLAGS@ @LDFLAGS@
+
+ DL_LD = @DL_LD@
+-DL_LDFLAGS = @DL_LDFLAGS@
++DL_LDFLAGS = @DL_LDFLAGS@ @LDFLAGS@
+
+ SONAME_FLAGS = @SONAME_FLAGS@
+
diff --git a/sci-mathematics/octave/octave-3.2.4-r1.ebuild b/sci-mathematics/octave/octave-3.2.4-r1.ebuild
new file mode 100644
index 000000000000..f7c36181d4bb
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.2.4-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.2.4-r1.ebuild,v 1.1 2010/03/06 18:40:19 bicatali Exp $
+
+EAPI="2"
+inherit flag-o-matic xemacs-elisp-common
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc emacs fltk fftw opengl readline sparse test xemacs zlib"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+# add media-gfx/graphicsmagick[cxx] when keyworded in arches
+RDEPEND="dev-libs/libpcre
+ media-libs/qhull
+ sci-libs/qrupdate
+ sci-mathematics/glpk
+ sci-visualization/gnuplot
+ sys-libs/ncurses
+ virtual/lapack
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ fltk? ( x11-libs/fltk:1.1[opengl?] )
+ fftw? ( sci-libs/fftw:3.0 )
+ opengl? ( virtual/opengl media-libs/ftgl )
+ sparse? ( sci-libs/arpack
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ xemacs? ( app-editors/xemacs )
+ zlib? ( sys-libs/zlib )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ || ( dev-texlive/texlive-genericrecommended
+ app-text/ptex )
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.2.0_parallel_make.patch
+ epatch "${FILESDIR}"/${PN}-3.2.0_as_needed.patch
+ epatch "${FILESDIR}"/${PN}-3.2.4-imread.patch
+ epatch "${FILESDIR}"/${PN}-3.2.4-ldflags.patch
+}
+
+src_configure() {
+ use fltk || export FLTK_CONFIG="no"
+ # hdf5 disabled because not really useful (bug #)
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --without-hdf5 \
+ --with-qrupdate \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_enable readline) \
+ $(use_with curl) \
+ $(use_with fftw) \
+ $(use_with opengl framework-opengl) \
+ $(use_with sparse arpack) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_with zlib)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use xemacs; then
+ cd "${S}/emacs"
+ xemacs-elisp-comp *.el
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+
+ if use emacs || use xemacs; then
+ cd emacs
+ exeinto /usr/bin
+ doexe octave-tags || die "Failed to install octave-tags"
+ doman octave-tags.1 || die "Failed to install octave-tags.1"
+ if use xemacs; then
+ xemacs-elisp-install ${PN} *.el *.elc
+ fi
+ cd ..
+ fi
+ use test && dodoc test/fntests.log
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+}