summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-03 08:39:25 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-03 08:39:25 +0000
commit8db2a6918b9b01f1108db4c47706decf5081301d (patch)
tree9824cf669ba6b04130334ccf5c98e99217e6e6c6 /sci-mathematics/polymake
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8db2a6918b9b01f1108db4c47706decf5081301d.tar.gz
gentoo-2-8db2a6918b9b01f1108db4c47706decf5081301d.tar.bz2
gentoo-2-8db2a6918b9b01f1108db4c47706decf5081301d.zip
initial import, fixes bug 207033
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/polymake')
-rw-r--r--sci-mathematics/polymake/ChangeLog10
-rw-r--r--sci-mathematics/polymake/metadata.xml14
-rw-r--r--sci-mathematics/polymake/polymake-2.9.8.ebuild76
3 files changed, 100 insertions, 0 deletions
diff --git a/sci-mathematics/polymake/ChangeLog b/sci-mathematics/polymake/ChangeLog
new file mode 100644
index 000000000000..2d66657e65a4
--- /dev/null
+++ b/sci-mathematics/polymake/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/polymake
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.1 2010/11/03 08:39:25 tomka Exp $
+
+*polymake-2.9.8 (03 Nov 2010)
+
+ 03 Nov 2010; Thomas Kahle <tomka@gentoo.org> +polymake-2.9.8.ebuild,
+ +metadata.xml:
+ initial import, fixes bug 207033
+
diff --git a/sci-mathematics/polymake/metadata.xml b/sci-mathematics/polymake/metadata.xml
new file mode 100644
index 000000000000..dd2a5cb0ecda
--- /dev/null
+++ b/sci-mathematics/polymake/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>tomka@gentoo.org</email>
+<name>Thomas Kahle</name>
+</maintainer>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+Polymake started out as a tool for the algorithmic treatment of convex
+polyhedra. By now it also deals with finite simplicial complexes,
+tight spans of finite metric spaces, and other objects.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/polymake/polymake-2.9.8.ebuild b/sci-mathematics/polymake/polymake-2.9.8.ebuild
new file mode 100644
index 000000000000..940a86bf059c
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.9.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.9.8.ebuild,v 1.1 2010/11/03 08:39:25 tomka Exp $
+
+EAPI=2
+
+inherit flag-o-matic
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://www.opt.tu-darmstadt.de/polymake/lib/exe/fetch.php/download/${P}.tar.bz2"
+
+HOMEPAGE="http://www.opt.tu-darmstadt.de/polymake"
+
+IUSE=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/gmp
+ dev-libs/libxml2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu
+ >=virtual/jdk-1.5.0"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ # Fixing makefile to not use escaped characters
+ sed -i 's/uname -p/uname -i/' support/locate_build_dir
+ # Remove stripping from install.pl
+ sed -i '/system "strip $to"/d' support/install.pl
+
+ # Configure is asking questions
+ # First accept defaults
+ touch defaults || die "Cannot touch file"
+ emake configure < defaults
+ rm defaults
+
+ OFLAG=`get-flag -O`
+
+ # Now inject our answers
+ cd "${S}/build.`uname -i`"
+ sed -i 's,InstallTop=.*$,InstallTop=/usr/share/polymake,' conf.make
+ sed -i 's,InstallArch=.*$,InstallArch=/usr/lib/polymake,' conf.make
+ sed -i 's,InstallBin=.*$,InstallBin=/usr/bin,' conf.make
+ sed -i 's,InstallDoc=.*$,InstallDoc=/usr/share/doc/${PF},' conf.make
+ sed -i "s,CXXOPT=.*$,CXXOPT=${OFLAG}," conf.make
+ cd "${S}"
+ # The makefile respects CXXFLAGS and friends from the environment
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+}
+
+pkg_postinst(){
+ elog "Polymake uses Perl Modules compiled during install."
+ elog "If something does not work after an upgrade of Perl"
+ elog "please re-emerge polymake"
+ elog " "
+ elog "This version of polymake does not ship docs. Sorry."
+ elog "Help can be found on http://www.opt.tu-darmstadt.de/polymake_doku/ "
+ elog " "
+ elog "On first start, polymake will ask you about the locations"
+ elog "of external programs it can use."
+ elog "If the initial run crashes, please report to the developers."
+}