summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-04 09:18:51 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-04 09:18:51 +0000
commitca43365e6ba0e8378e2fb68cefcf8460c9af6fd3 (patch)
tree21fa49dc2da6881e7566d9650ad8b74c627bd09e /sci-mathematics/rngstreams
parentUpdate media-video/makemkv EULA from the 1.7.6 tarball (diff)
downloadgentoo-2-ca43365e6ba0e8378e2fb68cefcf8460c9af6fd3.tar.gz
gentoo-2-ca43365e6ba0e8378e2fb68cefcf8460c9af6fd3.tar.bz2
gentoo-2-ca43365e6ba0e8378e2fb68cefcf8460c9af6fd3.zip
sci-mathematics/rngstreams: Move to autotool-utils.eclass
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/rngstreams')
-rw-r--r--sci-mathematics/rngstreams/ChangeLog6
-rw-r--r--sci-mathematics/rngstreams/metadata.xml4
-rw-r--r--sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild15
3 files changed, 11 insertions, 14 deletions
diff --git a/sci-mathematics/rngstreams/ChangeLog b/sci-mathematics/rngstreams/ChangeLog
index 2fd99dedd7dd..49e19d822a08 100644
--- a/sci-mathematics/rngstreams/ChangeLog
+++ b/sci-mathematics/rngstreams/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/rngstreams
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/ChangeLog,v 1.2 2012/06/26 22:15:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/ChangeLog,v 1.3 2012/07/04 09:18:51 jlec Exp $
+
+ 04 Jul 2012; Justin Lecher <jlec@gentoo.org> rngstreams-1.0.1.ebuild,
+ metadata.xml:
+ Move to autotool-utils.eclass
26 Jun 2012; Sebastien Fabbro <fabbros@gentoo.org> rngstreams-1.0.1.ebuild:
keyword ~amd64-linux and x86-linux. switch to EAPI4
diff --git a/sci-mathematics/rngstreams/metadata.xml b/sci-mathematics/rngstreams/metadata.xml
index 232b1e848442..f2f1196ee510 100644
--- a/sci-mathematics/rngstreams/metadata.xml
+++ b/sci-mathematics/rngstreams/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
RngStreams is a C implementation of a high quality uniform random
number generator that supports multiple "independent" streams of
uniform random numbers. It has been written by Pierre L'Ecuyer and
diff --git a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
index 42384837c7d6..e07cb145ed5e 100644
--- a/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
+++ b/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild
@@ -1,29 +1,22 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild,v 1.2 2012/06/26 22:15:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/rngstreams/rngstreams-1.0.1.ebuild,v 1.3 2012/07/04 09:18:51 jlec Exp $
EAPI=4
+inherit autotools-utils
+
DESCRIPTION="Multiple independent streams of pseudo-random numbers"
HOMEPAGE="http://statmath.wu.ac.at/software/RngStreams/"
SRC_URI="${HOMEPAGE}${P}.tar.gz"
LICENSE="GPL-3"
-
SLOT=0
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs"
-DEPEND=""
-RDEPEND=""
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
src_install() {
- default
+ autotools-utils_src_install
use doc && dohtml -r doc/rngstreams.html/* && dodoc doc/${PN}.pdf
if use examples; then
emake distclean -C examples