summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 11:07:42 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 11:07:42 +0000
commit2c41db72bc5dbf781a88568aa85780daa4876d5b (patch)
treeca5022cb393e590c8941c4248796ba5205b9106a /sci-mathematics
parentBump network to 2.4.2.0 (diff)
downloadgentoo-2-2c41db72bc5dbf781a88568aa85780daa4876d5b.tar.gz
gentoo-2-2c41db72bc5dbf781a88568aa85780daa4876d5b.tar.bz2
gentoo-2-2c41db72bc5dbf781a88568aa85780daa4876d5b.zip
Byte-compile the emacs elisp files, to make Mx agda2-type-and-context work, fixes https://code.google.com/p/agda/issues/detail?id=792. Loosen the alex DEPEND.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/agda/ChangeLog7
-rw-r--r--sci-mathematics/agda/agda-2.3.2.1-r1.ebuild11
2 files changed, 15 insertions, 3 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 3692082b1149..cfea6a146f8f 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.23 2013/09/13 06:58:23 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.24 2013/10/19 11:07:42 gienah Exp $
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> agda-2.3.2.1-r1.ebuild:
+ Byte-compile the emacs elisp files, to make Mx agda2-type-and-context work,
+ fixes https://code.google.com/p/agda/issues/detail?id=792. Loosen the alex
+ DEPEND.
*agda-2.3.2.1-r1 (13 Sep 2013)
diff --git a/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild b/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild
index 7df444320289..c730dd776823 100644
--- a/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild
+++ b/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild,v 1.1 2013/09/13 06:58:23 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.2.1-r1.ebuild,v 1.2 2013/10/19 11:07:42 gienah Exp $
EAPI=5
@@ -64,7 +64,8 @@ src_prepare() {
CABAL_FILE=${MY_PN}.cabal cabal_chdeps \
'binary >= 0.4.4 && < 0.6' 'binary >= 0.4.4 && < 0.8' \
'hashtables == 1.0.*' 'hashtables >= 1.0 && < 1.2' \
- 'haskell-src-exts >= 1.9.6 && < 1.14' 'haskell-src-exts >= 1.9.6 && < 1.15'
+ 'haskell-src-exts >= 1.9.6 && < 1.14' 'haskell-src-exts >= 1.9.6 && < 1.15' \
+ 'alex >= 2.3.1 && < 3.1' 'alex >= 2.3.1 && < 3.2'
sed -e '/.*emacs-mode.*$/d' \
-e '/^executable agda/,$d' \
-i "${S}/${MY_PN}.cabal" \
@@ -84,6 +85,12 @@ src_configure() {
$(cabal_flag epic epic)
}
+src_compile() {
+ elisp-compile src/data/emacs-mode/*.el \
+ || die "Failed to compile emacs mode"
+ haskell-cabal_src_compile
+}
+
src_install() {
haskell-cabal_src_install
elisp-install ${PN} src/data/emacs-mode/*.el \