summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-06 12:21:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-06 12:21:32 +0000
commit47809b6d37b1604fd7cbb2d673bfd7af3f830530 (patch)
treefba6a1ed8b41cef0ff0caa5e840fe9e20fc1462b /sci-mathematics
parentMajor version bump: default macro system is now hygienic (diff)
downloadgentoo-2-47809b6d37b1604fd7cbb2d673bfd7af3f830530.tar.gz
gentoo-2-47809b6d37b1604fd7cbb2d673bfd7af3f830530.tar.bz2
gentoo-2-47809b6d37b1604fd7cbb2d673bfd7af3f830530.zip
Removed reference pdf doxygen generation, see bug #264774
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/ginac/ChangeLog5
-rw-r--r--sci-mathematics/ginac/ginac-1.5.1.ebuild26
2 files changed, 17 insertions, 14 deletions
diff --git a/sci-mathematics/ginac/ChangeLog b/sci-mathematics/ginac/ChangeLog
index ecc5d75cf06f..688f28c5d4c6 100644
--- a/sci-mathematics/ginac/ChangeLog
+++ b/sci-mathematics/ginac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/ginac
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.25 2009/04/03 09:44:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ChangeLog,v 1.26 2009/04/06 12:21:32 bicatali Exp $
+
+ 06 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> ginac-1.5.1.ebuild:
+ Removed reference pdf doxygen generation, see bug #264774
*ginac-1.5.1 (03 Apr 2009)
diff --git a/sci-mathematics/ginac/ginac-1.5.1.ebuild b/sci-mathematics/ginac/ginac-1.5.1.ebuild
index b184efda4179..9d6b62d23e9f 100644
--- a/sci-mathematics/ginac/ginac-1.5.1.ebuild
+++ b/sci-mathematics/ginac/ginac-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.5.1.ebuild,v 1.1 2009/04/03 09:44:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.5.1.ebuild,v 1.2 2009/04/06 12:21:32 bicatali Exp $
EAPI=2
inherit eutils
@@ -32,12 +32,12 @@ src_prepare() {
src_compile() {
emake || die "emake failed"
if use doc; then
- # need to run twice to get the references right (you know, latex)
- # do not add die function at the first one
- make pdf
- emake pdf || die "emake pdf failed"
- cd doc/reference
- emake html || die "emake html failed"
+ cd "${S}/doc/reference"
+ #pdf generation for reference failed (1.5.1), bug #264774
+ #emake html pdf || die "emake doc reference failed"
+ emake html || die "emake ref failed"
+ cd "${S}/doc/tutorial"
+ emake ginac.pdf ginac.html || die "emake doc tutorial failed"
fi
}
@@ -48,12 +48,12 @@ src_install() {
if use doc; then
cd doc
insinto /usr/share/doc/${PF}
- doins \
- examples/ginac-examples.pdf \
- reference/reference.pdf \
- tutorial/ginac.pdf \
- || die "pdf doc install failed"
- dohtml -r reference/html_files/*
+ newins tutorial/ginac.pdf tutorial.pdf || die "tutorial install failed"
+ #newins reference/ginac.pdf reference.pdf || die "ref install failed"
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/* || die
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
insinto /usr/share/doc/${PF}/examples
doins examples/*.cpp examples/ginac-examples.txt
fi