summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2015-04-02 12:27:59 +0000
committerThomas Kahle <tomka@gentoo.org>2015-04-02 12:27:59 +0000
commit660756796b401db31c599607f3ff3ee70dbb3e90 (patch)
tree3d215bd47a88bbe97ebf641e7cff124ae05261aa /sci-mathematics
parentBump attoparsec to 0.12.1.5 (diff)
downloadgentoo-2-660756796b401db31c599607f3ff3ee70dbb3e90.tar.gz
gentoo-2-660756796b401db31c599607f3ff3ee70dbb3e90.tar.bz2
gentoo-2-660756796b401db31c599607f3ff3ee70dbb3e90.zip
Bump to 2.4.5 (542682)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/flint/ChangeLog9
-rw-r--r--sci-mathematics/flint/flint-2.4.5.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/sci-mathematics/flint/ChangeLog b/sci-mathematics/flint/ChangeLog
index 37bec6f8c649..7af4ed5584e3 100644
--- a/sci-mathematics/flint/ChangeLog
+++ b/sci-mathematics/flint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/flint
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.10 2014/11/25 23:27:26 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.11 2015/04/02 12:27:59 tomka Exp $
+
+*flint-2.4.5 (02 Apr 2015)
+
+ 02 Apr 2015; Thomas Kahle <tomka@gentoo.org> +flint-2.4.5.ebuild:
+ Bump to 2.4.5 (542682)
25 Nov 2014; Julian Ospald <hasufell@gentoo.org> metadata.xml:
drop maintainership
diff --git a/sci-mathematics/flint/flint-2.4.5.ebuild b/sci-mathematics/flint/flint-2.4.5.ebuild
new file mode 100644
index 000000000000..928d2a3e01c1
--- /dev/null
+++ b/sci-mathematics/flint/flint-2.4.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/flint-2.4.5.ebuild,v 1.1 2015/04/02 12:27:59 tomka Exp $
+
+EAPI="5"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Fast Library for Number Theory"
+HOMEPAGE="http://www.flintlib.org/"
+SRC_URI="http://www.flintlib.org/${P}.tar.gz"
+
+RESTRICT="mirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gc ntl static-libs test"
+
+RDEPEND="dev-libs/gmp
+ dev-libs/mpfr
+ gc? ( dev-libs/boehm-gc )
+ ntl? ( dev-libs/ntl )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/texlive-core
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.3-libdir.patch \
+ "${FILESDIR}"/${PN}-2.4.3-whitespaces.patch \
+ "${FILESDIR}"/${PN}-2.4.3-cflags-ldflags.patch \
+ "${FILESDIR}"/${PN}-2.4.4-test.patch
+}
+
+src_configure() {
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-gmp="${EPREFIX}/usr" \
+ --with-mpfr="${EPREFIX}/usr" \
+ $(usex ntl "--with-ntl=${EPREFIX}/usr" "") \
+ $(use_enable static-libs static) \
+ $(usex gc "--with-gc=${EPREFIX}/usr" "") \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ || die
+}
+
+src_compile() {
+ emake verbose
+
+ if use doc ; then
+ emake -C doc/latex
+ fi
+}
+
+src_test() {
+ emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ einstalldocs
+ use doc && dodoc doc/latex/flint-manual.pdf
+}