summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-12-11 16:56:08 +0000
committerMichael Januszewski <spock@gentoo.org>2008-12-11 16:56:08 +0000
commit6dea8ac30f3d18366af57173ccb417c9285d24c1 (patch)
treeb8980eb989598c857bf05b190a5b78e0f8482f86 /sci-mathematics
parentStable on alpha, bug #249727 (diff)
downloadgentoo-2-6dea8ac30f3d18366af57173ccb417c9285d24c1.tar.gz
gentoo-2-6dea8ac30f3d18366af57173ccb417c9285d24c1.tar.bz2
gentoo-2-6dea8ac30f3d18366af57173ccb417c9285d24c1.zip
Version bump (bug #245489).
(Portage version: 2.1.6/cvs/Linux 2.6.27 x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gimps/ChangeLog8
-rwxr-xr-xsci-mathematics/gimps/files/gimps-25.7-init.d37
-rw-r--r--sci-mathematics/gimps/files/mprime-25.7.bpatchbin0 -> 159 bytes
-rw-r--r--sci-mathematics/gimps/gimps-25.7.ebuild73
4 files changed, 117 insertions, 1 deletions
diff --git a/sci-mathematics/gimps/ChangeLog b/sci-mathematics/gimps/ChangeLog
index 4440c6c935b6..c72658497fc0 100644
--- a/sci-mathematics/gimps/ChangeLog
+++ b/sci-mathematics/gimps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gimps
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.24 2008/11/04 20:06:38 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/ChangeLog,v 1.25 2008/12/11 16:56:07 spock Exp $
+
+*gimps-25.7 (11 Dec 2008)
+
+ 11 Dec 2008; Michał Januszewski <spock@gentoo.org>
+ +files/gimps-25.7-init.d, +files/mprime-25.7.bpatch, +gimps-25.7.ebuild:
+ Version bump (bug #245489).
04 Nov 2008; Michał Januszewski <spock@gentoo.org> gimps-25.6.ebuild:
Remove unnecessary dependencies from RDEPEND.
diff --git a/sci-mathematics/gimps/files/gimps-25.7-init.d b/sci-mathematics/gimps/files/gimps-25.7-init.d
new file mode 100755
index 000000000000..5f6cb6f35c61
--- /dev/null
+++ b/sci-mathematics/gimps/files/gimps-25.7-init.d
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e "${GIMPS_DIR}" ]; then
+ einfo "Creating ${GIMPS_DIR}"
+ /bin/mkdir "${GIMPS_DIR}"
+ fi
+
+ /bin/chown -R ${USER}:${GROUP} ${GIMPS_DIR}
+
+ if [ ! -e "${GIMPS_DIR}/local.txt" ]; then
+ eerror "GIMPS has not been configured. Please configure it manually before"
+ eerror "starting this initscript."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting GIMPS"
+ start-stop-daemon --quiet --start -b --exec /opt/gimps/mprime \
+ --chdir ${GIMPS_DIR} --chuid ${USER}:${GROUP} \
+ -- -w${GIMPS_DIR} ${GIMPS_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping GIMPS"
+ start-stop-daemon --quiet --stop --exec /opt/gimps/mprime
+ eend $?
+}
diff --git a/sci-mathematics/gimps/files/mprime-25.7.bpatch b/sci-mathematics/gimps/files/mprime-25.7.bpatch
new file mode 100644
index 000000000000..4ddd15628473
--- /dev/null
+++ b/sci-mathematics/gimps/files/mprime-25.7.bpatch
Binary files differ
diff --git a/sci-mathematics/gimps/gimps-25.7.ebuild b/sci-mathematics/gimps/gimps-25.7.ebuild
new file mode 100644
index 000000000000..9ceceb3d5a2f
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-25.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gimps/gimps-25.7.ebuild,v 1.1 2008/12/11 16:56:07 spock Exp $
+
+IUSE=""
+DESCRIPTION="GIMPS - The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+SRC_URI="amd64? ( ftp://mersenne.org/gimps/mprime${PV/./}-linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/mprime${PV/./}.tar.gz )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+DEPEND="x86? ( dev-util/bsdiff )"
+RDEPEND="net-misc/curl"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_EXECSTACK="opt/gimps/mprime"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use x86 ; then
+ bspatch mprime mprime.fixed "${FILESDIR}/mprime-25.7.bpatch" || \
+ die "failed to apply binary patch for libcurl.so.4"
+ mv mprime.fixed mprime
+ fi
+}
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ cp mprime "${D}/${I}"
+ chmod 0555 "${D}/${I}/mprime"
+ chown root:0 "${D}/${I}"
+ chown root:0 "${D}/${I}/mprime"
+
+ dodoc license.txt readme.txt stress.txt whatsnew.txt undoc.txt
+
+ newinitd "${FILESDIR}/gimps-25.7-init.d" gimps
+ newconfd "${FILESDIR}/gimps-25.6-conf.d" gimps
+}
+
+pkg_postinst() {
+ echo
+ einfo "You can use \`/etc/init.d/gimps start\` to start a GIMPS client in the"
+ einfo "background at boot. Have a look at /etc/conf.d/gimps and check some"
+ einfo "configuration options."
+ einfo
+ einfo "If you are a new user, you will need to configure GIMPS before"
+ einfo "starting the initscript. To do so, run:"
+ einfo " ${I}/mprime -w/var/lib/gimps"
+ einfo "followed by:"
+ einfo " chown nobody:nobody /var/lib/gimps/*"
+ einfo
+ einfo "If you have an existing GIMPS account, follow the instructions at:"
+ einfo " http://mersenne.org/freesoft/#upgradeusers"
+ einfo "and do not blindy restart gimps."
+ echo
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}