summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-28 17:44:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-28 17:44:49 +0000
commit9065ee21dd6f559e60714c7dbaa55194ebed15c5 (patch)
tree1bd78a87ad6dddebe21a293626e908e242b9d854 /sci-mathematics
parentUnmask new ldb and sssd revisions (diff)
downloadgentoo-2-9065ee21dd6f559e60714c7dbaa55194ebed15c5.tar.gz
gentoo-2-9065ee21dd6f559e60714c7dbaa55194ebed15c5.tar.bz2
gentoo-2-9065ee21dd6f559e60714c7dbaa55194ebed15c5.zip
Version bump, switch to EAPI5
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/yacas/ChangeLog9
-rw-r--r--sci-mathematics/yacas/yacas-1.3.4.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sci-mathematics/yacas/ChangeLog b/sci-mathematics/yacas/ChangeLog
index 0d0ceb2f33e0..b59ac2b60ac0 100644
--- a/sci-mathematics/yacas/ChangeLog
+++ b/sci-mathematics/yacas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/yacas
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.35 2012/12/11 18:52:52 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/ChangeLog,v 1.36 2014/05/28 17:44:49 bicatali Exp $
+
+*yacas-1.3.4 (28 May 2014)
+
+ 28 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +yacas-1.3.4.ebuild:
+ Version bump, switch to EAPI5
*yacas-1.3.3 (11 Dec 2012)
diff --git a/sci-mathematics/yacas/yacas-1.3.4.ebuild b/sci-mathematics/yacas/yacas-1.3.4.ebuild
new file mode 100644
index 000000000000..a5f1a1db5218
--- /dev/null
+++ b/sci-mathematics/yacas/yacas-1.3.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/yacas/yacas-1.3.4.ebuild,v 1.1 2014/05/28 17:44:49 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils java-pkg-opt-2
+
+DESCRIPTION="General purpose computer algebra system"
+HOMEPAGE="http://yacas.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/backups/${P}.tar.gz"
+
+SLOT="0/1"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc java static-libs server"
+
+DEPEND="java? ( >=virtual/jdk-1.6 )"
+RDEPEND="java? ( >=virtual/jre-1.6 )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc html-doc)
+ $(use_enable server)
+ --with-html-dir="/usr/share/doc/${PF}/html"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use java; then
+ cd "${BUILD_DIR}"/JavaYacas || die
+ # -j1 because of file generation dependence
+ emake -j1 -f makefile.yacas
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use java; then
+ cd "${BUILD_DIR}}"/JavaYacas || die
+ java-pkg_dojar yacas.jar
+ java-pkg_dolauncher jyacas --main net.sf.yacas.YacasConsole
+ insinto /usr/share/${PN}
+ doins "${S}"/JavaYacas/{hints.txt,yacasconsole.html}
+ fi
+}