summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2009-08-26 18:36:00 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2009-08-26 18:36:00 +0000
commit95cf4e410355c6b375e461ba3bc98ecc097b2933 (patch)
treecde125262c7de8e208e97328289d30d9301be9f8 /sci-mathematics
parentVersion bump. Now gmp and gf2x are forced. Fixed parallel building, and hopef... (diff)
downloadgentoo-2-95cf4e410355c6b375e461ba3bc98ecc097b2933.tar.gz
gentoo-2-95cf4e410355c6b375e461ba3bc98ecc097b2933.tar.bz2
gentoo-2-95cf4e410355c6b375e461ba3bc98ecc097b2933.zip
Renaming netperf to snns-netperf to avoid file collision with net-analyzer/netperf, see bug #248322.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/snns/ChangeLog13
-rw-r--r--sci-mathematics/snns/snns-4.2-r8.ebuild126
2 files changed, 137 insertions, 2 deletions
diff --git a/sci-mathematics/snns/ChangeLog b/sci-mathematics/snns/ChangeLog
index 4dc35969ea14..1bae933723db 100644
--- a/sci-mathematics/snns/ChangeLog
+++ b/sci-mathematics/snns/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-mathematics/snns
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.13 2008/05/29 14:37:00 hawking Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/ChangeLog,v 1.14 2009/08/26 18:36:00 phosphan Exp $
+
+ 26 Aug 2009; Patrick Kursawe <phosphan@gentoo.org> +snns-4.2-r8.ebuild:
+ Renaming netperf to snns-netperf to avoid file collision with
+ net-analyzer/netperf, see bug #248322.
+
+*snns-4.3 (07 Feb 2009)
+
+ 07 Feb 2009; Patrick Kursawe <phosphan@gentoo.org> +snns-4.3.ebuild:
+ Upgrade to new version, almost identical to 4.2 + Python-patches.
29 May 2008; Ali Polatel <hawking@gentoo.org> snns-4.2-r7.ebuild:
python_mod_compile is ROOT aware. Use ${python} instead of python.
diff --git a/sci-mathematics/snns/snns-4.2-r8.ebuild b/sci-mathematics/snns/snns-4.2-r8.ebuild
new file mode 100644
index 000000000000..fcae95c4c38a
--- /dev/null
+++ b/sci-mathematics/snns/snns-4.2-r8.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/snns/snns-4.2-r8.ebuild,v 1.3 2009/08/26 18:36:00 phosphan Exp $
+
+inherit eutils python multilib
+
+MY_P="SNNSv${PV}"
+MYPATCH="${P}-20040227"
+MYPYTHONEXT="PySNNS-20040605"
+MYPYTHONPATCH="PythonFunctionSupport-20050210.patch"
+
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPATCH}.patch.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )
+ python? ( http://download.berlios.de/snns-dev/${MYPYTHONEXT}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPYTHONPATCH}.gz )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="X doc python"
+
+DEPEND="X? ( x11-proto/xproto
+ x11-libs/Xaw3d )
+ >=sys-apps/sed-4
+ python? ( >=dev-lang/python-2.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack ${MYPATCH}.patch.gz
+ epatch ${MYPATCH}.patch
+ if use python; then
+ unpack ${MYPYTHONEXT}.tar.gz
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-fPIC-python.patch
+ cd "${WORKDIR}"
+ unpack ${MYPYTHONPATCH}.gz
+ cd "${S}"
+ epatch "${WORKDIR}"/${MYPYTHONPATCH}
+ fi
+ cd "${S}"/xgui/sources
+ for file in *.c; do
+ sed -e "s:X11/Xaw/:X11/Xaw3d/:g" -i "${file}"
+ done
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ # parallel make sometimes fails (phosphan)
+ make ${compileopts} || die "make failed"
+
+ if use python; then
+ python_version
+ cd python
+ ${python} setup.py build || die "could not build python extension"
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ mv ${D}/usr/bin/netperf ${D}/usr/bin/snns-netperf
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > "${D}"/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ python_version
+ cd python
+ ${python} setup.py install --prefix="${D}"/usr || die "could not install python module"
+ cp -pPR examples "${D}"/usr/share/doc/${PF}/python-examples
+ chmod +x "${D}"/usr/share/doc/${PF}/python-examples/*.py
+ newdoc README README.python
+ cd "${S}"
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins "${DISTDIR}"/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
+
+pkg_postinst() {
+ if use python; then
+ einfo "Pre-compiling Python module"
+ python_version
+ for file in __init__.py util.py; do
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/snns/${file}
+ done
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ einfo "Cleaning up python stuff"
+ python_mod_cleanup
+ fi
+}