summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-03-20 13:11:47 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-03-20 13:11:47 +0000
commitbd2250b51bbee11a4568d3e0e9d48d54ed4165f3 (patch)
treebe24903290ffd467ed2b91b4f6e08a94da83ba9f /sci-mathematics
parentVersion bump. (diff)
downloadgentoo-2-bd2250b51bbee11a4568d3e0e9d48d54ed4165f3.tar.gz
gentoo-2-bd2250b51bbee11a4568d3e0e9d48d54ed4165f3.tar.bz2
gentoo-2-bd2250b51bbee11a4568d3e0e9d48d54ed4165f3.zip
Added patch to fix linking problems on amd64. This fixes bug #166521.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/scilab/ChangeLog7
-rw-r--r--sci-mathematics/scilab/files/scilab-4.1-java-pic.patch30
-rw-r--r--sci-mathematics/scilab/scilab-4.1.ebuild4
3 files changed, 38 insertions, 3 deletions
diff --git a/sci-mathematics/scilab/ChangeLog b/sci-mathematics/scilab/ChangeLog
index b2120c5f4070..704670ab50fe 100644
--- a/sci-mathematics/scilab/ChangeLog
+++ b/sci-mathematics/scilab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/scilab
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.34 2007/03/01 23:10:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/ChangeLog,v 1.35 2007/03/20 13:11:47 markusle Exp $
+
+ 20 Mar 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/scilab-4.1-java-pic.patch, scilab-4.1.ebuild:
+ Added patch to fix linking problems on amd64.
+ This fixes bug #166521.
01 Mar 2007; Markus Dittrich <markusle@gentoo.org>
-files/gzvt2-add-gtk2-flags.patch, -scilab-3.1.1-r3.ebuild,
diff --git a/sci-mathematics/scilab/files/scilab-4.1-java-pic.patch b/sci-mathematics/scilab/files/scilab-4.1-java-pic.patch
new file mode 100644
index 000000000000..411c29c06be4
--- /dev/null
+++ b/sci-mathematics/scilab/files/scilab-4.1-java-pic.patch
@@ -0,0 +1,30 @@
+diff -Naur scilab-4.1.old/routines/Javasci/Makefile.in scilab-4.1/routines/Javasci/Makefile.in
+--- scilab-4.1.old/routines/Javasci/Makefile.in 2006-07-19 05:08:44.000000000 -0400
++++ scilab-4.1/routines/Javasci/Makefile.in 2007-03-11 14:09:00.000000000 -0400
+@@ -13,7 +13,7 @@
+ OBJSC= javasci_SciStringArray.o javasci_globals.o javasci_Scilab.o javasci_Scilab2.o javasci_SciDoubleArray.o javasci_SciComplexArray.o @GCCFIX@
+ OBJSF =
+ OBJS = $(OBJSC)
+-CFLAGS = $(CC_OPTIONS) $(JAVAINC)
++CFLAGS = $(CC_OPTIONS) -fPIC $(JAVAINC)
+ FLIBS=@FLIBS@
+
+ include ../../Makefile.incl
+diff -Naur scilab-4.1.old/routines/Javasci/Makefile.linux scilab-4.1/routines/Javasci/Makefile.linux
+--- scilab-4.1.old/routines/Javasci/Makefile.linux 2005-05-23 07:22:17.000000000 -0400
++++ scilab-4.1/routines/Javasci/Makefile.linux 2007-03-11 14:09:17.000000000 -0400
+@@ -4,4 +4,4 @@
+ @echo Creation of $(LIBRARY)
+ @$(RM) $@;
+ @echo "linking";
+- @$(FC) -Wl,-shared -g -o $@ $(OBJS) $(DEFAULTS) $(LIBR) $(TCLTK_LIBS) $(XLIBS) $(TERMCAPLIB);
++ $(CC) -shared -o $@ $(OBJS) $(TCLTK_LIBS) $(XLIBS) $(TERMCAPLIB);
+diff -Naur scilab-4.1.old/routines/Javasci/Makefile.linux64 scilab-4.1/routines/Javasci/Makefile.linux64
+--- scilab-4.1.old/routines/Javasci/Makefile.linux64 2006-06-13 10:14:49.000000000 -0400
++++ scilab-4.1/routines/Javasci/Makefile.linux64 2007-03-11 14:09:51.000000000 -0400
+@@ -4,4 +4,4 @@
+ @echo Creation of $(LIBRARY)
+ @$(RM) $@;
+ @echo "linking";
+- @$(FC) -shared -g -o $@ $(OBJS) $(DEFAULTS) $(LIBR) $(TCLTK_LIBS) $(XLIBS) $(TERMCAPLIB);
++ $(CC) -shared -o $@ $(OBJS) $(TCLTK_LIBS) $(XLIBS) $(TERMCAPLIB);
diff --git a/sci-mathematics/scilab/scilab-4.1.ebuild b/sci-mathematics/scilab/scilab-4.1.ebuild
index a711be2e882f..f49637a44125 100644
--- a/sci-mathematics/scilab/scilab-4.1.ebuild
+++ b/sci-mathematics/scilab/scilab-4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.ebuild,v 1.3 2007/03/01 23:10:55 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/scilab/scilab-4.1.ebuild,v 1.4 2007/03/20 13:11:47 markusle Exp $
inherit eutils fortran toolchain-funcs multilib autotools java-pkg-opt-2
@@ -57,7 +57,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-4.0-makefile.patch
- epatch "${FILESDIR}"/${PN}-4.0-java-pic.patch
+ epatch "${FILESDIR}"/${P}-java-pic.patch
epatch "${FILESDIR}"/${P}-header-fix.patch
epatch "${FILESDIR}"/${P}-examples.patch