summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 13:32:18 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 13:32:18 +0000
commitf80fddb8ab794313e307a41cdb75104a76fcc944 (patch)
tree9a55ad8b74455279d9a0246e55606bec69b5a048 /sci-mathematics
parentsci-mathematics/octave: Use tc-getPKG_CONFIG from toolchain-funcs.eclass inst... (diff)
downloadgentoo-2-f80fddb8ab794313e307a41cdb75104a76fcc944.tar.gz
gentoo-2-f80fddb8ab794313e307a41cdb75104a76fcc944.tar.bz2
gentoo-2-f80fddb8ab794313e307a41cdb75104a76fcc944.zip
sci-mathematics/jags: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; drop old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/jags/ChangeLog9
-rw-r--r--sci-mathematics/jags/jags-3.2.0.ebuild44
-rw-r--r--sci-mathematics/jags/jags-3.3.0.ebuild21
-rw-r--r--sci-mathematics/jags/metadata.xml4
4 files changed, 21 insertions, 57 deletions
diff --git a/sci-mathematics/jags/ChangeLog b/sci-mathematics/jags/ChangeLog
index ebe13b373c1b..bed19c221ee7 100644
--- a/sci-mathematics/jags/ChangeLog
+++ b/sci-mathematics/jags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/jags
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.11 2012/12/01 03:03:01 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/ChangeLog,v 1.12 2013/02/21 13:32:18 jlec Exp $
+
+ 21 Feb 2013; Justin Lecher <jlec@gentoo.org> -jags-3.2.0.ebuild,
+ jags-3.3.0.ebuild, metadata.xml:
+ Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config;
+ drop old
01 Dec 2012; Thomas Kahle <tomka@gentoo.org> jags-3.3.0.ebuild:
marked x86 per bug 444058
diff --git a/sci-mathematics/jags/jags-3.2.0.ebuild b/sci-mathematics/jags/jags-3.2.0.ebuild
deleted file mode 100644
index 375f92b82630..000000000000
--- a/sci-mathematics/jags/jags-3.2.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-3.2.0.ebuild,v 1.4 2012/05/04 07:46:51 jdhore Exp $
-
-EAPI=4
-inherit autotools-utils
-
-MYP="JAGS-${PV}"
-
-DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
-HOMEPAGE="http://www-fis.iarc.fr/~martyn/software/jags/"
-SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/3.x/Source/${MYP}.tar.gz"
-LICENSE="GPL-2"
-IUSE="doc"
-
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( virtual/latex-base
- dev-texlive/texlive-latexextra
- )"
-
-S="${WORKDIR}/${MYP}"
-
-src_configure() {
- myeconfargs=(
- --with-blas="$(pkg-config --libs blas)"
- --with-lapack="$(pkg-config --libs lapack)"
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile all $(use doc && echo docs)
-}
-
-src_install() {
- autotools-utils_src_install
- use doc && dodoc ${AUTOTOOLS_BUILD_DIR}/doc/manual/*.pdf
-}
diff --git a/sci-mathematics/jags/jags-3.3.0.ebuild b/sci-mathematics/jags/jags-3.3.0.ebuild
index d476a03ae98e..cf19dc797f08 100644
--- a/sci-mathematics/jags/jags-3.3.0.ebuild
+++ b/sci-mathematics/jags/jags-3.3.0.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-3.3.0.ebuild,v 1.3 2012/12/01 03:03:01 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/jags/jags-3.3.0.ebuild,v 1.4 2013/02/21 13:32:18 jlec Exp $
EAPI=4
-inherit autotools-utils
+
+inherit autotools-utils toolchain-funcs
MYP="JAGS-${PV}"
@@ -16,20 +17,22 @@ IUSE="doc"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-RDEPEND="virtual/blas
+RDEPEND="
+ virtual/blas
virtual/lapack"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( virtual/latex-base
- dev-texlive/texlive-latexextra
- )"
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
S="${WORKDIR}/${MYP}"
src_configure() {
myeconfargs=(
- --with-blas="$(pkg-config --libs blas)"
- --with-lapack="$(pkg-config --libs lapack)"
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
)
autotools-utils_src_configure
}
diff --git a/sci-mathematics/jags/metadata.xml b/sci-mathematics/jags/metadata.xml
index cfbc499c6d25..85bc1ce292bf 100644
--- a/sci-mathematics/jags/metadata.xml
+++ b/sci-mathematics/jags/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
JAGS is Just Another Gibbs Sampler. It is a program for analysis of
Bayesian hierarchical models using Markov Chain Monte Carlo (MCMC)
simulation not wholly unlike BUGS.