summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-24 23:08:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-24 23:08:26 +0000
commit85d7b7a33a9b1c4e393310abcd00c1ada1519d69 (patch)
treebede4810b0339d3bd8660ae23701daa6e5de68c6 /sci-physics/lhapdf
parentDrop support for old AMR libs (diff)
downloadgentoo-2-85d7b7a33a9b1c4e393310abcd00c1ada1519d69.tar.gz
gentoo-2-85d7b7a33a9b1c4e393310abcd00c1ada1519d69.tar.bz2
gentoo-2-85d7b7a33a9b1c4e393310abcd00c1ada1519d69.zip
Version bump. Now installs PDFs data separately with a data use flag. (needs large disk space). Thanks Ben Bannier for his work, bug #278107.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/ChangeLog9
-rw-r--r--sci-physics/lhapdf/lhapdf-5.7.1.ebuild74
-rw-r--r--sci-physics/lhapdf/metadata.xml3
3 files changed, 85 insertions, 1 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 89c32a4169bb..35f3daf17940 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.5 2009/02/24 13:16:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.6 2009/07/24 23:08:26 bicatali Exp $
+
+*lhapdf-5.7.1 (24 Jul 2009)
+
+ 24 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-5.7.1.ebuild,
+ metadata.xml:
+ Version bump. Now installs PDFs data separately with a data use flag
+ (needs large disk space). Thanks Ben Bannier for his work, bug #278107.
*lhapdf-5.7.0 (23 Feb 2009)
diff --git a/sci-physics/lhapdf/lhapdf-5.7.1.ebuild b/sci-physics/lhapdf/lhapdf-5.7.1.ebuild
new file mode 100644
index 000000000000..0c53ab712b66
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-5.7.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.7.1.ebuild,v 1.1 2009/07/24 23:08:26 bicatali Exp $
+
+EAPI=2
+inherit check-reqs
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+
+# data built with svn export http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${P}.tar.gz
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/cteq61.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/cteq61.LHpdf
+ data? ( mirror://gentoo/${P}-pdf.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx -data doc examples python test"
+
+DEPEND="doc? ( app-doc/doxygen[latex] )
+ python? ( dev-lang/swig )"
+RDEPEND=""
+
+pkg_setup() {
+ if use data; then
+ # Check if we have enough free diskspace to install
+ CHECKREQS_DISK_BUILD="1800"
+ check_reqs
+ fi
+}
+
+src_prepare() {
+ # do not create extra latex docs
+ sed -i \
+ -e 's/GENERATE_LATEX.*=YES/GENERATE_LATEX = NO/g' \
+ ccwrap/Doxyfile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx ccwrap) \
+ $(use_enable cxx old-ccwrap ) \
+ $(use_enable python pyext) \
+ $(use_enable doc doxygen)
+}
+
+src_test() {
+ LHAPATH="${DISTDIR}" emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO AUTHORS ChangeLog
+
+ if use data; then
+ elog "Installing data files"
+ insinto /usr/share/lhapdf/PDFSets
+ doins "${S}-pdf"/* || die
+ fi
+
+ # leftover
+ rm -rf "${D}"/usr/share/${PN}/doc || die
+ if use doc && use cxx; then
+ # default doc install buggy
+ insinto /usr/share/doc/${PF}
+ doins -r ccwrap/doxy/html || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{f,cc} || die
+ fi
+}
diff --git a/sci-physics/lhapdf/metadata.xml b/sci-physics/lhapdf/metadata.xml
index 0ee0caff5105..c5a1839b31c4 100644
--- a/sci-physics/lhapdf/metadata.xml
+++ b/sci-physics/lhapdf/metadata.xml
@@ -15,4 +15,7 @@
version 4.1 onwards a configuration script facilitates the
installation of LHAPDF.
</longdescription>
+<use>
+ <flag name='data'>Install all Parton Density Function data sets system-wide</flag>
+</use>
</pkgmetadata>