summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-12-10 17:14:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-12-10 17:14:10 +0000
commit88e2d3e0534b79196fc088031d025ae65c19c126 (patch)
treef8f4c67e948c208dc662e4f77d743f64c0e22f81 /sci-physics
parentx86 stable, bug 292455 (diff)
downloadgentoo-2-88e2d3e0534b79196fc088031d025ae65c19c126.tar.gz
gentoo-2-88e2d3e0534b79196fc088031d025ae65c19c126.tar.bz2
gentoo-2-88e2d3e0534b79196fc088031d025ae65c19c126.zip
Propagate compiler correctly, bug #296043
(Portage version: 2.2_rc56/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant/ChangeLog6
-rw-r--r--sci-physics/geant/geant-4.9.2_p02.ebuild22
2 files changed, 20 insertions, 8 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 220710bfca3a..6cbda13ee4d4 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.35 2009/12/07 18:25:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.36 2009/12/10 17:14:10 bicatali Exp $
+
+ 10 Dec 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ geant-4.9.2_p02.ebuild:
+ Propagate compiler correctly, bug #296043
07 Dec 2009; Jeroen Roovers <jer@gentoo.org> geant-3.21.14-r2.ebuild,
geant-4.9.2_p02.ebuild:
diff --git a/sci-physics/geant/geant-4.9.2_p02.ebuild b/sci-physics/geant/geant-4.9.2_p02.ebuild
index 2e8619fe5818..566d6e894627 100644
--- a/sci-physics/geant/geant-4.9.2_p02.ebuild
+++ b/sci-physics/geant/geant-4.9.2_p02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.5 2009/12/07 18:25:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.6 2009/12/10 17:14:10 bicatali Exp $
EAPI=2
@@ -57,15 +57,22 @@ src_prepare() {
# fix bad zlib dependency
epatch "${FILESDIR}"/${PN}-4.9.2-zlib.patch
- # propagate user's flags.
+ # propagate user's flags and compiler settings
sed -i -e 's/-o/$(LDFLAGS) -o/g' source/GNUmakefile || die
sed -i \
+ -e '/CXX.*:=.*g++/d' \
+ -e '/FC.*:=.*gfortran/d' \
+ -e 's/\(CXXFLAGS.*:=\).*/\1 -ansi/' \
+ -e '/CXXFLAGS.*+=.*pipe/d' \
-e "/CXXFLAGS.*=.*-O2/s:=.*:= ${CXXFLAGS}:" \
- -e "/FCFLAGS.*=.*-O2/s:=.*:= ${FFLAGS:--O2}:" \
+ -e "/FCFLAGS.*=.*-O2/s:=.*:= ${FCFLAGS}:" \
-e "/CCFLAGS.*=.*-O2/s:=.*:= ${CFLAGS}:" \
-e "s:-Wl,-soname:${LDFLAGS} -Wl,-soname:g" \
-e "s/libq\*/lib\[q,Q\]t*/g" \
config/sys/Linux*gmk || die "flag substitution failed"
+ sed -i \
+ -e 's:g++:$(CXX):g' \
+ config/*.gmk || die "sed for forced g++ failed"
# fix forced lib directory
sed -i \
@@ -88,6 +95,11 @@ src_prepare() {
sed -i \
-e 's:$(G4LIB)/$(G4SYSTEM):$(G4TMP):g' \
config/globlib.gmk || die "sed globlib.gmk failed"
+
+ # work around a non defined fortran compiler
+ use geant3 && export FC=$(tc-getFC)
+ # don't worry about the g++ name of the file, we remove all specific
+ export G4SYSTEM=Linux-g++
}
src_configure() {
@@ -96,10 +108,6 @@ src_configure() {
# we set env var G4LIB in src_install()
# to avoid confusing make
export GEANT4_LIBDIR=/usr/$(get_libdir)/${PN}${PV1}
-
- # these should always to be set
- [[ $(tc-getCXX) = ic*c ]] && export G4SYSTEM=Linux-icc \
- || export G4SYSTEM=Linux-g++
export G4INSTALL="${S}"
export G4WORKDIR="${S}"
export G4INCLUDE="${D}/usr/include/${PN}"