summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-05-18 15:57:20 +0000
committerMichael Januszewski <spock@gentoo.org>2008-05-18 15:57:20 +0000
commit80ec91faa582fe3ad109c71c4d3a0e0fb11323ef (patch)
treec3ad2fab3158d85af2952ec7ad10aa06d5f9b986 /sci-visualization
parentamd64/x86 stable, bug #221063 (diff)
downloadgentoo-2-80ec91faa582fe3ad109c71c4d3a0e0fb11323ef.tar.gz
gentoo-2-80ec91faa582fe3ad109c71c4d3a0e0fb11323ef.tar.bz2
gentoo-2-80ec91faa582fe3ad109c71c4d3a0e0fb11323ef.zip
Add a patch to allow compilation with GCC 4.3.
(Portage version: 2.1.5)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/opendx/ChangeLog6
-rw-r--r--sci-visualization/opendx/files/opendx-4.4.4-gcc43.patch117
-rw-r--r--sci-visualization/opendx/opendx-4.4.4.ebuild3
3 files changed, 124 insertions, 2 deletions
diff --git a/sci-visualization/opendx/ChangeLog b/sci-visualization/opendx/ChangeLog
index 0de7212baab1..0def66e530fe 100644
--- a/sci-visualization/opendx/ChangeLog
+++ b/sci-visualization/opendx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/opendx
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.11 2008/04/05 17:24:33 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/ChangeLog,v 1.12 2008/05/18 15:57:19 spock Exp $
+
+ 18 May 2008; Michał Januszewski <spock@gentoo.org>
+ +files/opendx-4.4.4-gcc43.patch, opendx-4.4.4.ebuild:
+ Add a patch to allow compilation with GCC 4.3.
05 Apr 2008; Markus Dittrich <markusle@gentoo.org> opendx-4.3.2-r1.ebuild,
opendx-4.4.4.ebuild:
diff --git a/sci-visualization/opendx/files/opendx-4.4.4-gcc43.patch b/sci-visualization/opendx/files/opendx-4.4.4-gcc43.patch
new file mode 100644
index 000000000000..40349fe8ecb4
--- /dev/null
+++ b/sci-visualization/opendx/files/opendx-4.4.4-gcc43.patch
@@ -0,0 +1,117 @@
+diff -Naurp dx-4.4.4-orig/src/uipp/base/Application.h dx-4.4.4/src/uipp/base/Application.h
+--- dx-4.4.4-orig/src/uipp/base/Application.h 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/base/Application.h 2008-05-18 17:26:10.000000000 +0200
+@@ -49,7 +49,7 @@ class Application : public UIComponent,
+ //
+ // The main program needs to access protected member functions.
+ //
+- friend int main(unsigned int argc,
++ friend int main(int argc,
+ char** argv);
+
+
+diff -Naurp dx-4.4.4-orig/src/uipp/dxui/Main.C dx-4.4.4/src/uipp/dxui/Main.C
+--- dx-4.4.4-orig/src/uipp/dxui/Main.C 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/dxui/Main.C 2008-05-18 17:25:13.000000000 +0200
+@@ -48,7 +48,7 @@ extern unsigned long _etext;
+ //
+ const char *AssertMsgString = "Internal error detected at \"%s\":%d.\n";
+
+-int main(unsigned int argc,
++int main(int argc,
+ char** argv)
+ {
+ #if defined(HAVE_HCLXMINIT)
+@@ -104,7 +104,7 @@ int main(unsigned int argc,
+
+ // add *tearOffModel:: XmTEAR_OFF_ENABLED/XmTEAR_OFF_DISABLED
+ XmRepTypeInstallTearOffModelConverter();
+- if (!theApplication->initialize(&argc, argv))
++ if (!theApplication->initialize((unsigned int*)&argc, argv))
+ exit(1);
+
+ theApplication->handleEvents();
+diff -Naurp dx-4.4.4-orig/src/uipp/mb/Main.C dx-4.4.4/src/uipp/mb/Main.C
+--- dx-4.4.4-orig/src/uipp/mb/Main.C 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/mb/Main.C 2008-05-18 17:24:57.000000000 +0200
+@@ -22,7 +22,7 @@ extern "C" void HCLXmInit();
+ //
+ const char *AssertMsgString = "Internal error detected at \"%s\":%d.\n";
+
+-int main(unsigned int argc,
++int main(int argc,
+ char** argv)
+ {
+ #if defined(HAVE_HCLXMINIT)
+@@ -39,7 +39,7 @@ int main(unsigned int argc,
+ theApplication = new MBApplication("MB");
+ }
+
+- theApplication->initialize(&argc, argv);
++ theApplication->initialize((unsigned int*)&argc, argv);
+ theApplication->handleEvents();
+
+ delete theApplication;
+diff -Naurp dx-4.4.4-orig/src/uipp/prompter/Main.C dx-4.4.4/src/uipp/prompter/Main.C
+--- dx-4.4.4-orig/src/uipp/prompter/Main.C 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/prompter/Main.C 2008-05-18 17:25:53.000000000 +0200
+@@ -17,7 +17,7 @@ extern "C" void HCLXmInit();
+ #endif
+
+
+-int main(unsigned int argc,
++int main(int argc,
+ char** argv)
+ {
+ #if defined(HAVE_HCLXMINIT)
+@@ -34,7 +34,7 @@ int main(unsigned int argc,
+ theApplication = new GARApplication("GAR");
+ }
+
+- theApplication->initialize(&argc, argv);
++ theApplication->initialize((unsigned int*)&argc, argv);
+ theApplication->handleEvents();
+
+ delete theApplication;
+diff -Naurp dx-4.4.4-orig/src/uipp/startup/Main.C dx-4.4.4/src/uipp/startup/Main.C
+--- dx-4.4.4-orig/src/uipp/startup/Main.C 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/startup/Main.C 2008-05-18 17:25:38.000000000 +0200
+@@ -14,7 +14,7 @@
+ extern "C" void HCLXmInit();
+ #endif
+
+-int main(unsigned int argc,
++int main(int argc,
+ char** argv)
+ {
+ #if defined(HAVE_HCLXMINIT)
+@@ -31,7 +31,7 @@ int main(unsigned int argc,
+ theApplication = new StartupApplication("Startup");
+ }
+
+- theApplication->initialize(&argc, argv);
++ theApplication->initialize((unsigned int*)&argc, argv);
+ theApplication->handleEvents();
+
+ delete theApplication;
+diff -Naurp dx-4.4.4-orig/src/uipp/tutor/Main.C dx-4.4.4/src/uipp/tutor/Main.C
+--- dx-4.4.4-orig/src/uipp/tutor/Main.C 2008-05-18 17:09:32.000000000 +0200
++++ dx-4.4.4/src/uipp/tutor/Main.C 2008-05-18 17:25:27.000000000 +0200
+@@ -31,7 +31,7 @@ extern "C" void HCLXmInit();
+ //
+ const char *AssertMsgString = "Internal error detected at \"%s\":%d.\n";
+
+-int main(unsigned int argc,
++int main(int argc,
+ char** argv)
+ {
+ #if defined(HAVE_HCLXMINIT)
+@@ -58,7 +58,7 @@ int main(unsigned int argc,
+ theApplication = new TutorApplication("DXTutor");
+ }
+
+- if (!theApplication->initialize(&argc, argv))
++ if (!theApplication->initialize((unsigned int*)&argc, argv))
+ exit(1);
+
+ theApplication->handleEvents();
diff --git a/sci-visualization/opendx/opendx-4.4.4.ebuild b/sci-visualization/opendx/opendx-4.4.4.ebuild
index 19941646be41..ace29de46b0a 100644
--- a/sci-visualization/opendx/opendx-4.4.4.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.4 2008/04/05 17:24:33 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/opendx/opendx-4.4.4.ebuild,v 1.5 2008/05/18 15:57:19 spock Exp $
# Set SMP="no" to force disable of SMP compilation.
# Set SMP="yes" to force enable of SMP compilation.
@@ -74,6 +74,7 @@ src_unpack() {
fi
epatch "${FILESDIR}"/${PN}-compressed-man.patch
+ epatch "${FILESDIR}"/${PN}-4.4.4-gcc43.patch
eautoreconf || die "Failed running eautoreconf."
}