summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-22 20:45:13 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-22 20:45:13 +0000
commit20b5c3bd00266c634c39df3ccb4b0d3b3b2af7f1 (patch)
tree38f21207abe9fc46764ebaa9c82bc5808cc785f6 /sys-apps/baselayout
parentx86 stable, bug #196572 (diff)
downloadgentoo-2-20b5c3bd00266c634c39df3ccb4b0d3b3b2af7f1.tar.gz
gentoo-2-20b5c3bd00266c634c39df3ccb4b0d3b3b2af7f1.tar.bz2
gentoo-2-20b5c3bd00266c634c39df3ccb4b0d3b3b2af7f1.zip
Fix upgrade/downgrade paths.
(Portage version: 2.1.3.15)
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild14
2 files changed, 10 insertions, 10 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 92b120a7b802..18688650bc43 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.439 2007/10/11 15:56:40 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.440 2007/10/22 20:45:13 uberlord Exp $
# See the rc-scripts ChangeLog in subversion for release info:
# http://sources.gentoo.org/viewcvs.py/*checkout*/baselayout/trunk/ChangeLog
+ 22 Oct 2007; Roy Marples <uberlord@gentoo.org>
+ baselayout-2.0.0_rc5.ebuild:
+ Fix upgrade/downgrade paths.
+
*baselayout-2.0.0_rc5 (11 Oct 2007)
11 Oct 2007; Roy Marples <uberlord@gentoo.org>
diff --git a/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild b/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild
index 0f96b80d89d4..42fe86e14b12 100644
--- a/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild
+++ b/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild,v 1.2 2007/10/12 06:46:05 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-2.0.0_rc5.ebuild,v 1.3 2007/10/22 20:45:13 uberlord Exp $
inherit flag-o-matic eutils toolchain-funcs multilib
@@ -172,16 +172,12 @@ pkg_postinst() {
. "${ROOT}etc/conf.d/rc"
svcdir="${svcdir:-/var/lib/init.d}"
einfo "Moving state from ${ROOT}${svcdir} to ${ROOT}lib/rcscripts/init.d"
- cp -RPp "${ROOT}${svcdir}"/* "${ROOT}"lib/rcscripts/init.d
- rm -rf "${ROOT}"lib/rcscripts/init.d/daemons \
- "${ROOT}"lib/rcscripts/init.d/console
+ cp -RPp "${ROOT}${svcdir}"/* "${ROOT}"lib/rc/init.d
+ rm -rf "${ROOT}"lib/rc/init.d/daemons \
+ "${ROOT}"lib/rc/init.d/console
umount "${ROOT}${svcdir}" 2>/dev/null
rm -rf "${ROOT}${svcdir}"
)
- elif has_version "<sys-apps/${PN}-2.0.0_alpha4" ; then
- # The format has changed since 1.13
- rm -rf "${ROOT}"lib/rcscripts/init.d/daemons \
- "${ROOT}"lib/rcscripts/init.d/console
elif has_version "<sys-apps/${PN}-2.0.0_rc5" ; then
if [ -d "${ROOT}"lib/rcscripts/init.d ] ; then
einfo "Moving state from ${ROOT}lib/rcscripts/init.d to ${ROOT}lib/rc/init.d"
@@ -292,7 +288,7 @@ pkg_postrm() {
)
elif has_version "<sys-apps/${PN}-2.0.0_rc5" ; then
einfo "Moving state from ${ROOT}lib/rc/init.d to ${ROOT}lib/rcscripts/init.d"
- mkdir -p "${ROOT}"lib/scripts/init.d
+ mkdir -p "${ROOT}"lib/rcscripts/init.d
cp -RPp "${ROOT}"lib/rc/init.d/* "${ROOT}"lib/rcscripts/init.d
umount "${ROOT}"lib/rc/init.d 2>/dev/null
rm -rf "${ROOT}"lib/rc/init.d