summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-02-26 00:07:41 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-02-26 00:07:41 +0000
commitce57c21aea0ead689685595fec155b4303b03f0f (patch)
treee623543d4eba53b1056e10b85424b9ae7a15c509 /sys-apps/baselayout
parentsome small fixes. (diff)
downloadgentoo-2-ce57c21aea0ead689685595fec155b4303b03f0f.tar.gz
gentoo-2-ce57c21aea0ead689685595fec155b4303b03f0f.tar.bz2
gentoo-2-ce57c21aea0ead689685595fec155b4303b03f0f.zip
misc fixes
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog9
-rw-r--r--sys-apps/baselayout/baselayout-1.7.1-r2.ebuild (renamed from sys-apps/baselayout/baselayout-1.7.0-r1.ebuild)106
-rw-r--r--sys-apps/baselayout/files/digest-baselayout-1.7.0-r12
-rw-r--r--sys-apps/baselayout/files/digest-baselayout-1.7.1-r21
4 files changed, 67 insertions, 51 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index 64c84ada325e..8c5556c27570 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.3 2002/02/20 07:23:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.4 2002/02/26 00:07:41 azarah Exp $
+
+*baselayout-1.7.1-r2 (25 Feb 2002)
+
+ 25 Feb 2002; Martin Schlemmer <azarah@gentoo.org> baselayout-1.7.1-r2.ebuild :
+
+ Change devices to be created in ${D}/dev and not ${D}/lib/dev-state, as they
+ are for use only when devfs is not used.
*baselayout-1.7.1-r1 (20 Feb 2002)
diff --git a/sys-apps/baselayout/baselayout-1.7.0-r1.ebuild b/sys-apps/baselayout/baselayout-1.7.1-r2.ebuild
index 2aa080528756..2ccf6968b12c 100644
--- a/sys-apps/baselayout/baselayout-1.7.0-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-1.7.1-r2.ebuild
@@ -1,22 +1,25 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.7.0-r1.ebuild,v 1.1 2002/01/20 21:55:14 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.7.1-r2.ebuild,v 1.1 2002/02/26 00:07:41 azarah Exp $
-SV=1.2.5
+SV=1.2.6
#sysvinit version
SVIV=2.83
S=${WORKDIR}/rc-scripts-${SV}
S2=${WORKDIR}/sysvinit-${SVIV}/src
DESCRIPTION="Base layout for Gentoo Linux filesystem (incl. initscripts and sysvinit)"
-SRC_URI="http://www.ibiblio.org/gentoo/distfiles/rc-scripts-${SV}.tar.bz2
- ftp://metalab.unc.edu/pub/Linux/system/daemons/init/sysvinit-${SVIV}.tar.gz"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/daemons/init/sysvinit-${SVIV}.tar.gz"
+# http://www.ibiblio.org/gentoo/distfiles/rc-scripts-${SV}.tar.bz2"
HOMEPAGE="http://www.gentoo.org"
#This ebuild needs to be merged "live". You can't simply make a package of it and merge it later.
src_unpack() {
unpack ${A}
+
+ echo ">>> Unpacking rc-scripts-${SV}.tar.bz2"
+ tar -jxf ${FILESDIR}/rc-scripts-${SV}.tar.bz2
#fix CFLAGS for sysvinit stuff
cd ${S2}
@@ -60,10 +63,8 @@ keepdir() {
done
}
-src_install()
-{
- local foo
- local altmerge
+defaltmerge() {
+ #define the "altmerge" variable.
altmerge=0
#special ${T}/ROOT hack because ROOT gets automatically unset during src_install()
#(because it conflicts with some makefiles)
@@ -79,6 +80,13 @@ src_install()
altmerge=1
fi
fi
+}
+
+
+src_install()
+{
+ local foo
+ defaltmerge
keepdir /sbin
exeinto /sbin
doexe ${T}/runscript
@@ -92,7 +100,7 @@ src_install()
keepdir /var /var/run /var/lock/subsys
dosym ../var/tmp /usr/tmp
-keepdir /home
+ keepdir /home
keepdir /usr/include /usr/src /usr/portage /usr/X11R6/include/GL
dosym ../X11R6/include/X11 /usr/include/X11
dosym ../X11R6/include/GL /usr/include/GL
@@ -180,33 +188,14 @@ keepdir /home
dosym /usr/sbin/MAKEDEV /lib/dev-state/MAKEDEV
#this is not needed anymore...
#keepdir /lib/dev-state/pts /lib/dev-state/shm
- cd ${D}/lib/dev-state
else
#normal
keepdir /dev
keepdir /lib/dev-state
keepdir /dev/pts /dev/shm
dosym /usr/sbin/MAKEDEV /dev/MAKEDEV
- cd ${D}/dev
fi
- # we dont want to create devices if this is not a bootstrap and devfs
- # is used, as this was the cause for all the devfs problems we had
- if [ ! $altmerge -eq 1 ]
- then
- #These devices are also needed by many people and should be included
- echo "Making device nodes... (this could take a minute or so...)"
- ${S}/sbin/MAKEDEV generic-i386
- ${S}/sbin/MAKEDEV sg
- ${S}/sbin/MAKEDEV scd
- ${S}/sbin/MAKEDEV rtc
- ${S}/sbin/MAKEDEV audio
- ${S}/sbin/MAKEDEV hde
- ${S}/sbin/MAKEDEV hdf
- ${S}/sbin/MAKEDEV hdg
- ${S}/sbin/MAKEDEV hdh
- fi
-
cd ${S}/sbin
into /
dosbin rc rc-update
@@ -286,6 +275,26 @@ keepdir /home
}
pkg_postinst() {
+ #doing device node creation in pkg_postinst() now so they aren't recorded in CONTENTS.
+ #latest CVS-only version of Portage doesn't record device nodes in CONTENTS at all.
+ defaltmerge
+ # we dont want to create devices if this is not a bootstrap and devfs
+ # is used, as this was the cause for all the devfs problems we had
+ if [ ! $altmerge -eq 1 ]
+ then
+ cd ${D}/dev
+ #These devices are also needed by many people and should be included
+ echo "Making device nodes... (this could take a minute or so...)"
+ ${S}/sbin/MAKEDEV generic-i386
+ ${S}/sbin/MAKEDEV sg
+ ${S}/sbin/MAKEDEV scd
+ ${S}/sbin/MAKEDEV rtc
+ ${S}/sbin/MAKEDEV audio
+ ${S}/sbin/MAKEDEV hde
+ ${S}/sbin/MAKEDEV hdf
+ ${S}/sbin/MAKEDEV hdg
+ ${S}/sbin/MAKEDEV hdh
+ fi
#we create the /boot directory here so that /boot doesn't get deleted when a previous
#baselayout is unmerged with /boot unmounted.
install -d ${ROOT}/boot
@@ -337,25 +346,26 @@ EOF
fi
fi
- #force update of /etc/devfsd.conf
- #just until everybody upgrade that is ...
- if [ -e /etc/devfsd.conf ]
- then
- mv /etc/devfsd.conf /etc/devfsd.conf.old
- install -m0644 ${S}/etc/devfsd.conf /etc/devfsd.conf
-
- echo
- echo "*********************************************************"
- echo "* This release use a new form of /dev management, so *"
- echo "* /etc/devfsd.conf have moved from the devfsd package *"
- echo "* to this one. Any old versions will be renamed to *"
- echo "* /etc/devfsd.conf.old. Please verify that it actually *"
- echo "* do not save your settings before adding entries, and *"
- echo "* if you really need to, just add missing entries and *"
- echo "* try not to delete lines from the new devfsd.conf. *"
- echo "*********************************************************"
- echo
- fi
+#it should be ok now, and gets irritating to revert my changes all the time ;/
+# #force update of /etc/devfsd.conf
+# #just until everybody upgrade that is ...
+# if [ -e /etc/devfsd.conf ]
+# then
+# mv /etc/devfsd.conf /etc/devfsd.conf.old
+# install -m0644 ${S}/etc/devfsd.conf /etc/devfsd.conf
+#
+# echo
+# echo "*********************************************************"
+# echo "* This release use a new form of /dev management, so *"
+# echo "* /etc/devfsd.conf have moved from the devfsd package *"
+# echo "* to this one. Any old versions will be renamed to *"
+# echo "* /etc/devfsd.conf.old. Please verify that it actually *"
+# echo "* do not save your settings before adding entries, and *"
+# echo "* if you really need to, just add missing entries and *"
+# echo "* try not to delete lines from the new devfsd.conf. *"
+# echo "*********************************************************"
+# echo
+# fi
#restart devfsd
#we dont want to restart devfsd when bootstrapping, because it will
diff --git a/sys-apps/baselayout/files/digest-baselayout-1.7.0-r1 b/sys-apps/baselayout/files/digest-baselayout-1.7.0-r1
deleted file mode 100644
index 5fbdaa8f868e..000000000000
--- a/sys-apps/baselayout/files/digest-baselayout-1.7.0-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 7f769ca9ba6c06e43e75d1193cb7e81b rc-scripts-1.2.5.tar.bz2 51895
-MD5 b534cbb5bfdd1ed0fb08ec10757dd741 sysvinit-2.83.tar.gz 90334
diff --git a/sys-apps/baselayout/files/digest-baselayout-1.7.1-r2 b/sys-apps/baselayout/files/digest-baselayout-1.7.1-r2
new file mode 100644
index 000000000000..61806b06ce6f
--- /dev/null
+++ b/sys-apps/baselayout/files/digest-baselayout-1.7.1-r2
@@ -0,0 +1 @@
+MD5 b534cbb5bfdd1ed0fb08ec10757dd741 sysvinit-2.83.tar.gz 90334