summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-04-23 05:50:59 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-04-23 05:50:59 +0000
commit0b49bb850caee8811bd008562b12a1f04695f17a (patch)
treecda032d5a9107f02d24a56198c1db8c90be1ef41 /sys-apps/diffutils
parentfix the 2.5.68 patch to only apply if the irq changes are present (diff)
downloadgentoo-2-0b49bb850caee8811bd008562b12a1f04695f17a.tar.gz
gentoo-2-0b49bb850caee8811bd008562b12a1f04695f17a.tar.bz2
gentoo-2-0b49bb850caee8811bd008562b12a1f04695f17a.zip
replaced cp/sed with sed -i; DEPEND >=sys-apps/sed-4; rmvd some extr cds
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r3.ebuild35
1 files changed, 15 insertions, 20 deletions
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
index 6f3a19c521e9..6347a5206b4b 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild,v 1.7 2003/04/02 14:02:33 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r3.ebuild,v 1.8 2003/04/23 05:50:59 msterret Exp $
IUSE="nls build"
-inherit eutils || die "I lost my inheritence"
-inherit flag-o-matic || die "I lost my inheritence"
+inherit eutils || die "I lost my eutils inheritence"
+inherit flag-o-matic || die "I lost my flag-o-matic inheritence"
# sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
# this fixes bug #13502
@@ -21,22 +21,20 @@ SLOT="0"
LICENSE="GPL-2"
DEPEND="virtual/glibc
+ >=sys-apps/sed-4
nls? ( sys-devel/gettext )
!build? ( sys-apps/texinfo sys-apps/help2man )"
RDEPEND="virtual/glibc"
-
src_unpack() {
unpack ${A}
cd ${S}
- if [ -n "`use build`" ]
- then
+ if [ -n "`use build`" ] ; then
#disable texinfo building so we can remove the dep
- cp Makefile.in Makefile.in.orig
- sed -e 's:SUBDIRS = doc:SUBDIRS =:' \
- Makefile.in.orig > Makefile.in
+ sed -i -e 's:SUBDIRS = doc:SUBDIRS =:' \
+ Makefile.in || die "Makefile.in sed"
fi
# Build fails with make -j5 or greater on pentium4. This is because
@@ -44,20 +42,19 @@ src_unpack() {
# at the same time paths.h is generated. This patch just fix a small
# typeo that caused this. This closes bug #8934.
# <azarah@gentoo.org> (14 Oct 2002)
- cd ${S}; epatch ${FILESDIR}/${P}-Makefile-fix-typeo.patch
+ epatch ${FILESDIR}/${P}-Makefile-fix-typeo.patch
# Removes waitpid() call after pclose() on piped diff stream, closing
# bug #11728, thanks to D Wollmann <converter@dalnet-perl.org>
- cd ${S}; epatch ${FILESDIR}/${P}-sdiff-no-waitpid.patch
+ epatch ${FILESDIR}/${P}-sdiff-no-waitpid.patch
}
src_compile() {
local myconf=""
[ -z "`use nls`" ] && myconf="--disable-nls"
-
- econf --build=${CHOST} \
- ${myconf} || die
-
+
+ econf --build=${CHOST} ${myconf} || die "econf"
+
emake || die
}
@@ -66,13 +63,11 @@ src_install() {
datadir=${D}/usr/share \
infodir=${D}/usr/share/info \
mandir=${D}/usr/share/man \
- install || die
-
- if [ -z "`use build`" ]
- then
+ install || die "make install"
+
+ if [ -z "`use build`" ] ; then
dodoc COPYING ChangeLog NEWS README
else
rm -rf ${D}/usr/share/info
fi
}
-