summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:51:30 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:51:30 +0000
commit777ff18c76a4ca2b30c1cec056fa57f592e1a1ad (patch)
treea6782d5910347240e08570082074616e928378bf /sys-apps/diffutils
parentfixums (diff)
downloadgentoo-2-777ff18c76a4ca2b30c1cec056fa57f592e1a1ad.tar.gz
gentoo-2-777ff18c76a4ca2b30c1cec056fa57f592e1a1ad.tar.bz2
gentoo-2-777ff18c76a4ca2b30c1cec056fa57f592e1a1ad.zip
fixums
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/diffutils-2.7-r3.ebuild46
-rw-r--r--sys-apps/diffutils/diffutils-2.7-r4.ebuild49
2 files changed, 17 insertions, 78 deletions
diff --git a/sys-apps/diffutils/diffutils-2.7-r3.ebuild b/sys-apps/diffutils/diffutils-2.7-r3.ebuild
deleted file mode 100644
index 525111abe20c..000000000000
--- a/sys-apps/diffutils/diffutils-2.7-r3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r3.ebuild,v 1.1 2001/02/27 15:07:25 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools to make diffs and compare files"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/diffutils/${A}
- ftp://ftp.gnu.org/gnu/diffutils/${A}"
-
-HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-RDEPEND="virtual/glibc"
-src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --host=${CHOST} --prefix=/usr ${myconf}
-
- if [ -z "`use static`" ]
- then
- try pmake
- else
- try pmake LDFLAGS=-static
- fi
-
-}
-
-src_install() {
-
- try make prefix=${D}/usr infodir=${D}/usr/share/info install
-
- if [ -z "`use build`" ]
- then
- dodoc COPYING ChangeLog NEWS README
- else
- rm -rf ${D}/usr/share/info
- fi
-
-}
-
-
diff --git a/sys-apps/diffutils/diffutils-2.7-r4.ebuild b/sys-apps/diffutils/diffutils-2.7-r4.ebuild
index 469f73735e90..04dd11ff984c 100644
--- a/sys-apps/diffutils/diffutils-2.7-r4.ebuild
+++ b/sys-apps/diffutils/diffutils-2.7-r4.ebuild
@@ -1,20 +1,20 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r4.ebuild,v 1.3 2001/08/13 19:20:17 drobbins Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.7-r4.ebuild,v 1.4 2001/10/06 16:51:30 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Tools to make diffs and compare files"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/diffutils/${A}
- ftp://ftp.gnu.org/gnu/diffutils/${A}"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/diffutils/${P}.tar.gz ftp://ftp.gnu.org/gnu/diffutils/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+
if [ -z "`use build`" ]
then
DEPEND="$DEPEND sys-apps/texinfo"
fi
+
RDEPEND="virtual/glibc"
src_unpack() {
@@ -24,41 +24,26 @@ src_unpack() {
}
src_compile() {
-
- local myconf
- if [ -z "`use nls`" ]
- then
- myconf="--disable-nls"
- fi
- try ./configure --host=${CHOST} --prefix=/usr ${myconf}
-
+ local myconf
+ [ -z "`use nls`" ] && myconf="--disable-nls"
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die
if [ "`use build`" ]
then
#disable texinfo building so we can remove the dep
cp Makefile Makefile.orig
sed -e 's/^all: ${PROGRAMS} info/all: ${PROGRAMS}/g' Makefile.orig > Makefile
fi
-
- if [ -z "`use static`" ]
- then
- try emake
- else
- try emake LDFLAGS=-static
- fi
-
+ emake || die
}
src_install() {
-
- try make prefix=${D}/usr infodir=${D}/usr/share/info install
-
- if [ -z "`use build`" ]
- then
- dodoc COPYING ChangeLog NEWS README
- else
- rm -rf ${D}/usr/share/info
- fi
-
+ make prefix=${D}/usr infodir=${D}/usr/share/info install || die
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog NEWS README
+ else
+ rm -rf ${D}/usr/share/info
+ fi
}