summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-07-08 21:08:34 +0000
committerMike Frysinger <vapier@gentoo.org>2011-07-08 21:08:34 +0000
commit0380970787defa2ceb2a6981b20e1b1af2832841 (patch)
tree61d647c73d9234f9a3d89cc3d7faad119c177f62 /sys-apps/file
parentAdd missing metatada (diff)
downloadgentoo-2-0380970787defa2ceb2a6981b20e1b1af2832841.tar.gz
gentoo-2-0380970787defa2ceb2a6981b20e1b1af2832841.tar.bz2
gentoo-2-0380970787defa2ceb2a6981b20e1b1af2832841.zip
Add fix from upstream for postscript detection #368121 by Justin Brody and Shannon.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog9
-rw-r--r--sys-apps/file/file-5.07-r3.ebuild100
-rw-r--r--sys-apps/file/files/file-5.07-postscript-detect.patch16
3 files changed, 124 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index ba25b9728bfd..031f89667749 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.199 2011/06/06 23:50:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.200 2011/07/08 21:08:34 vapier Exp $
+
+*file-5.07-r3 (08 Jul 2011)
+
+ 08 Jul 2011; Mike Frysinger <vapier@gentoo.org> +file-5.07-r3.ebuild,
+ +files/file-5.07-postscript-detect.patch:
+ Add fix from upstream for postscript detection #368121 by Justin Brody and
+ Shannon.
*file-5.07-r2 (06 Jun 2011)
diff --git a/sys-apps/file/file-5.07-r3.ebuild b/sys-apps/file/file-5.07-r3.ebuild
new file mode 100644
index 000000000000..cd0cd193b741
--- /dev/null
+++ b/sys-apps/file/file-5.07-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.07-r3.ebuild,v 1.1 2011/07/08 21:08:34 vapier Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? *"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="python static-libs zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="magic.py"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-zip-detect.patch #367417
+ epatch "${FILESDIR}"/${P}-postscript-detect.patch #368121
+
+ elibtoolize
+ epunt_cxx
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
+
+wd() { echo ${WORKDIR}/build-${CHOST}; }
+do_configure() {
+ ECONF_SOURCE=${S}
+
+ mkdir "$(wd)"
+ pushd "$(wd)" >/dev/null
+
+ econf "$@"
+
+ popd >/dev/null
+}
+src_configure() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ ac_cv_header_zlib_h=no \
+ ac_cv_lib_z_gzopen=no \
+ CHOST=${CBUILD} \
+ CFLAGS=${BUILD_CFLAGS} \
+ CXXFLAGS=${BUILD_CXXFLAGS} \
+ CPPFLAGS=${BUILD_CPPFLAGS} \
+ LDFLAGS="${BUILD_LDFLAGS} -static" \
+ do_configure --disable-shared
+ fi
+
+ export ac_cv_header_zlib_h=$(usex zlib) ac_cv_lib_z_gzopen=$(usex zlib)
+ do_configure $(use_enable static-libs static)
+}
+
+do_make() {
+ emake -C "$(wd)" "$@" || die
+}
+src_compile() {
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
+ CHOST=${CBUILD} do_make -C src file
+ PATH=$(CHOST=${CBUILD} wd)/src:${PATH}
+ fi
+ do_make
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ do_make DESTDIR="${D}" install || die
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+ use static-libs || rm -f "${D}"/usr/lib*/libmagic.la
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/file-5.07-postscript-detect.patch b/sys-apps/file/files/file-5.07-postscript-detect.patch
new file mode 100644
index 000000000000..9945b0739038
--- /dev/null
+++ b/sys-apps/file/files/file-5.07-postscript-detect.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/368121
+http://bugs.gw.com/view.php?id=126
+
+fix from upstream
+
+--- magic/Magdir/printer
++++ magic/Magdir/printer
+@@ -5,7 +5,7 @@
+ #
+
+ # PostScript, updated by Daniel Quinlan (quinlan@yggdrasil.com)
+-0 string/t %! PostScript document text
++0 string %! PostScript document text
+ !:mime application/postscript
+ !:apple ASPSTEXT
+ >2 string PS-Adobe- conforming