summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-22 08:36:24 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-22 08:36:24 +0000
commitc7a92e3e1a811a098259c4edb13e71c11a0cba2a (patch)
tree09fe4a04ef4a898486a83a7097397cfd11b4eff8 /sys-apps/gentoo-systemd-integration
parentBackport the patch for security bug #485546. Backport patches from -207 to to... (diff)
downloadgentoo-2-c7a92e3e1a811a098259c4edb13e71c11a0cba2a.tar.gz
gentoo-2-c7a92e3e1a811a098259c4edb13e71c11a0cba2a.tar.bz2
gentoo-2-c7a92e3e1a811a098259c4edb13e71c11a0cba2a.zip
Version bump. The new version re-enables sysrq by default.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/ChangeLog9
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild9
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild28
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild4
4 files changed, 45 insertions, 5 deletions
diff --git a/sys-apps/gentoo-systemd-integration/ChangeLog b/sys-apps/gentoo-systemd-integration/ChangeLog
index 584554b82fb5..104cf8147529 100644
--- a/sys-apps/gentoo-systemd-integration/ChangeLog
+++ b/sys-apps/gentoo-systemd-integration/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/gentoo-systemd-integration
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.4 2013/09/11 11:49:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/ChangeLog,v 1.5 2013/09/22 08:36:24 mgorny Exp $
+
+*gentoo-systemd-integration-2 (22 Sep 2013)
+
+ 22 Sep 2013; Michał Górny <mgorny@gentoo.org>
+ +gentoo-systemd-integration-2.ebuild, gentoo-systemd-integration-1.ebuild,
+ gentoo-systemd-integration-9999.ebuild:
+ Version bump. The new version re-enables sysrq by default.
*gentoo-systemd-integration-1 (11 Sep 2013)
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild
index e6803b7eeaa6..b625096fb551 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild,v 1.1 2013/09/11 11:49:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-1.ebuild,v 1.2 2013/09/22 08:36:24 mgorny Exp $
EAPI=5
@@ -15,7 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""
-RDEPEND=">=sys-apps/systemd-206-r4"
+RDEPEND="
+ || (
+ >=sys-apps/systemd-206-r4
+ ( <sys-apps/systemd-205
+ >=sys-apps/systemd-204-r1 )
+ )"
src_configure() {
local myeconfargs=(
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
new file mode 100644
index 000000000000..5d790a15fc93
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-2.ebuild,v 1.1 2013/09/22 08:36:24 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://bitbucket.org/mgorny/gentoo-systemd-integration"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207"
+
+src_configure() {
+ local myeconfargs=(
+ "$(systemd_with_unitdir)"
+ # TODO: solve it better in the eclass
+ --with-systemdsystemgeneratordir="$(systemd_get_utildir)"/system-generators
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index ce2812c6971e..9f279a8df2b4 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild,v 1.4 2013/09/11 11:49:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild,v 1.5 2013/09/22 08:36:24 mgorny Exp $
EAPI=5
@@ -21,7 +21,7 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""
-RDEPEND=">=sys-apps/systemd-206-r4"
+RDEPEND=">=sys-apps/systemd-207"
#if LIVE
SRC_URI=