summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-29 02:34:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-29 02:34:37 +0000
commit340f1cdb10731ae658d7dee886287121c0df8898 (patch)
tree8cce5d97fa50b1c2fb60598b453849fa3e003d27 /sys-apps/groff
parentmake sure we actually install the login.defs file properly with USE=-pam :) (... (diff)
downloadgentoo-2-340f1cdb10731ae658d7dee886287121c0df8898.tar.gz
gentoo-2-340f1cdb10731ae658d7dee886287121c0df8898.tar.bz2
gentoo-2-340f1cdb10731ae658d7dee886287121c0df8898.zip
filter -Os on all arches #63938 and update texinfo DEPEND #63970
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/groff-1.19.1-r1.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/sys-apps/groff/groff-1.19.1-r1.ebuild b/sys-apps/groff/groff-1.19.1-r1.ebuild
index d0fa1d029147..e6ac531d088f 100644
--- a/sys-apps/groff/groff-1.19.1-r1.ebuild
+++ b/sys-apps/groff/groff-1.19.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r1.ebuild,v 1.5 2004/10/28 15:50:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.1-r1.ebuild,v 1.6 2004/10/29 02:34:37 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -15,7 +15,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 ~sparc ~x86"
IUSE="X"
DEPEND="virtual/libc
- >=sys-apps/texinfo-4.0"
+ >=sys-apps/texinfo-4.7-r1"
PDEPEND=">=sys-apps/man-1.5k-r1"
src_unpack() {
@@ -46,18 +46,12 @@ src_compile() {
export CC="$(tc-getCC)"
export CXX="$(tc-getCXX)"
- case ${ARCH} in
- alpha)
- # -Os causes segfaults, -O is probably a fine replacement
- # (fixes bug 36008, 06 Jan 2004 agriffis)
- replace-flags -Os -O
- ;;
- hppa)
- # -march=2.0 makes groff unable to finish the compile process
- export CFLAGS="${CFLAGS/-march=2.0/}"
- export CXXFLAGS="${CXXFLAGS/-march=2.0/}"
- ;;
- esac
+ # -Os causes segfaults, -O is probably a fine replacement
+ # (fixes bug 36008, 06 Jan 2004 agriffis)
+ replace-flags -Os -O
+
+ # -march=2.0 makes groff unable to finish the compile process
+ use hppa && replace-cpu-flags 2.0 1.0
# myconf="${myconf} `use_enable cjk multibyte`"