summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-27 22:20:13 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-27 22:20:13 +0000
commite284f183306b851e59f96c56c6220877c7a1bfac (patch)
tree74e4dcc9cc42731806150a3b99947397f76d9e4d /sys-apps/groff
parentNew ebuild with the ipv6 patch split to care for mmx/3dnow -mmx/-3dnow (diff)
downloadgentoo-2-e284f183306b851e59f96c56c6220877c7a1bfac.tar.gz
gentoo-2-e284f183306b851e59f96c56c6220877c7a1bfac.tar.bz2
gentoo-2-e284f183306b851e59f96c56c6220877c7a1bfac.zip
do not depend on netpbm, bug #12803
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog8
-rw-r--r--sys-apps/groff/files/digest-groff-1.18-r31
-rw-r--r--sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch17
-rw-r--r--sys-apps/groff/groff-1.18-r3.ebuild83
4 files changed, 108 insertions, 1 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index d1f86bf395a0..78d8fc108d82 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/groff
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.10 2002/12/26 04:52:15 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.11 2002/12/27 22:20:13 azarah Exp $
+
+*groff-1.18-r3 (27 Dec 2002)
+
+ 27 Dec 2002; Martin Schlemmer <azarah@gentoo.org> groff-1.18-r3.ebuild :
+ Disable generation of example files requiring us to DEPEND on netpbm.
+ This closes bug #12803.
*groff-1.18-r2 (26 Dec 2002)
diff --git a/sys-apps/groff/files/digest-groff-1.18-r3 b/sys-apps/groff/files/digest-groff-1.18-r3
new file mode 100644
index 000000000000..7163abdda273
--- /dev/null
+++ b/sys-apps/groff/files/digest-groff-1.18-r3
@@ -0,0 +1 @@
+MD5 31474119d1ef2ded0bd0692132d50d05 groff-1.18.tar.gz 2199488
diff --git a/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch b/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch
new file mode 100644
index 000000000000..50a138568bb0
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.18-no-netpbm-depend.patch
@@ -0,0 +1,17 @@
+--- groff-1.18/doc/Makefile.sub.orig 2002-12-27 22:10:47.000000000 +0200
++++ groff-1.18/doc/Makefile.sub 2002-12-27 22:11:18.000000000 +0200
+@@ -60,12 +60,12 @@
+ HTMLDOCIMAGEFILES=\
+ pic*
+
+-EXAMPLEFILES=\
++EXAMPLEFILES=#\
+ webpage.ms \
+ grnexmpl.g \
+ grnexmpl.me
+
+-PROCESSEDEXAMPLEFILES=\
++PROCESSEDEXAMPLEFILES=#\
+ webpage.ps \
+ gnu.eps \
+ gnu.png \
diff --git a/sys-apps/groff/groff-1.18-r3.ebuild b/sys-apps/groff/groff-1.18-r3.ebuild
new file mode 100644
index 000000000000..143c5b64cfe6
--- /dev/null
+++ b/sys-apps/groff/groff-1.18-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.18-r3.ebuild,v 1.1 2002/12/27 22:20:13 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Text formatter used for man pages"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/groff/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch ${FILESDIR}/${P}-infoext.patch
+
+ # Do not generate example files that require us to
+ # depend on netpbm.
+ epatch ${FILESDIR}/${P}-no-netpbm-depend.patch
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ [ -z "${CC}" ] && export CC="gcc"
+ [ -z "${CXX}" ] && export CXX="g++"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=\${inforoot} || die
+
+ # emake doesn't work
+ make || die
+
+ # Only build X stuff if we have X installed, but do
+ # not depend on it, else we get circular deps.
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ xmkmf || die
+ make depend all || die
+ fi
+}
+
+src_install() {
+ dodir /usr /usr/share/doc/${PF}/{examples,html}
+ make prefix=${D}/usr \
+ manroot=${D}/usr/share/man \
+ inforoot=${D}/usr/share/info \
+ docdir=${D}/usr/share/doc/${PF} \
+ install || die
+
+ if [ -n "`use X`" ] && [ -x /usr/X11R6/bin/xmkmf ]
+ then
+ cd ${S}/src/xditview
+ make DESTDIR=${D} \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ install \
+ install.man || die
+ fi
+
+ #the following links are required for xman
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+ dosym soelim /usr/bin/zsoelim
+
+ cd ${S}
+ dodoc BUG-REPORT COPYING ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}
+