summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-09-09 21:35:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-09-09 21:35:42 +0000
commitac1aede9084c9f1ae8b70a976dced985110becc6 (patch)
treea6e4589a184e9d8e83a24788c74828f1f82c7dcb /sys-apps/hbaapi/hbaapi-2.2.ebuild
parentintial ebuild; thx to C.Leuschen for ebuild and the plugin sources (diff)
downloadgentoo-2-ac1aede9084c9f1ae8b70a976dced985110becc6.tar.gz
gentoo-2-ac1aede9084c9f1ae8b70a976dced985110becc6.tar.bz2
gentoo-2-ac1aede9084c9f1ae8b70a976dced985110becc6.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'sys-apps/hbaapi/hbaapi-2.2.ebuild')
-rw-r--r--sys-apps/hbaapi/hbaapi-2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/hbaapi/hbaapi-2.2.ebuild b/sys-apps/hbaapi/hbaapi-2.2.ebuild
new file mode 100644
index 000000000000..5a8f3e157f51
--- /dev/null
+++ b/sys-apps/hbaapi/hbaapi-2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hbaapi/hbaapi-2.2.ebuild,v 1.1 2006/09/09 21:35:42 robbat2 Exp $
+
+DESCRIPTION="The Host Bus Adapter API for managing Fibre Channel Host Bus Adapters"
+HOMEPAGE="http://hbaapi.sourceforge.net/"
+MY_PN="${PN}_src"
+MY_P="${MY_PN}_${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz
+ mirror://gentoo/${P}.Makefile.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/${P}.Makefile ${S}/Makefile
+}
+
+src_compile() {
+ # not parallel safe!
+ emake -j1 all
+}
+
+src_install() {
+ into /usr
+ dolib.so libHBAAPI.so
+ dosbin hbaapitest
+ insinto /etc
+ doins ${FILESDIR}/hba.conf
+ dodoc readme.txt
+}