summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 20:17:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-25 20:17:12 +0000
commit18db6f8e0b8e17fd13f6c1ca3710a62b39391b3d (patch)
tree10bdf61354a1977e0972ab193e045f73205d28b6 /sys-apps/help2man
parentstable x86, bug 280080 (diff)
downloadgentoo-2-18db6f8e0b8e17fd13f6c1ca3710a62b39391b3d.tar.gz
gentoo-2-18db6f8e0b8e17fd13f6c1ca3710a62b39391b3d.tar.bz2
gentoo-2-18db6f8e0b8e17fd13f6c1ca3710a62b39391b3d.zip
Respect LDFLAGS (bug #181461).
(Portage version: 14155-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/ChangeLog10
-rw-r--r--sys-apps/help2man/files/help2man-1.36.4-respect-LDFLAGS.patch11
-rw-r--r--sys-apps/help2man/help2man-1.36.4-r1.ebuild40
3 files changed, 59 insertions, 2 deletions
diff --git a/sys-apps/help2man/ChangeLog b/sys-apps/help2man/ChangeLog
index ef49fee5bd8c..15043c679112 100644
--- a/sys-apps/help2man/ChangeLog
+++ b/sys-apps/help2man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/help2man
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.33 2007/02/20 19:51:42 eroyf Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/ChangeLog,v 1.34 2009/08/25 20:17:12 arfrever Exp $
+
+*help2man-1.36.4-r1 (25 Aug 2009)
+
+ 25 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +help2man-1.36.4-r1.ebuild, +files/help2man-1.36.4-respect-LDFLAGS.patch:
+ Respect LDFLAGS (bug #181461).
20 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org>
help2man-1.36.4.ebuild:
diff --git a/sys-apps/help2man/files/help2man-1.36.4-respect-LDFLAGS.patch b/sys-apps/help2man/files/help2man-1.36.4-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..e6d1f6f0811e
--- /dev/null
+++ b/sys-apps/help2man/files/help2man-1.36.4-respect-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- Makefile.in
++++ Makefile.in
+@@ -102,7 +102,7 @@
+
+ preload: $(preload).so
+ $(preload).so: $(srcdir)/$(preload).c
+- $(CC) $(CFLAGS) -o $@ -fPIC -shared $? $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ -fPIC -shared $? $(LIBS)
+
+ man: $(target).1
+ $(target).1: $(srcdir)/$(target).PL $(srcdir)/$(target).h2m
diff --git a/sys-apps/help2man/help2man-1.36.4-r1.ebuild b/sys-apps/help2man/help2man-1.36.4-r1.ebuild
new file mode 100644
index 000000000000..d7781ade1884
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.36.4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/help2man/help2man-1.36.4-r1.ebuild,v 1.1 2009/08/25 20:17:12 arfrever Exp $
+
+inherit eutils
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="http://www.gnu.org/software/help2man"
+SRC_URI="mirror://gnu/help2man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls elibc_glibc"
+
+RDEPEND="dev-lang/perl"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( nls? ( dev-perl/Locale-gettext
+ >=sys-devel/gettext-0.12.1-r1 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ local myconf
+ use elibc_glibc && myconf="${myconf} $(use_enable nls)" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog NEWS README THANKS
+}