summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-08 13:28:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-08 13:28:13 +0000
commit6492435af20d7035fd327994ae0dc91442fbefc4 (patch)
tree9751375003b1ff8ec2e1ab6fc19bfd066637c296 /sys-apps/hwids/hwids-99999999.ebuild
parentVersion bump; remove old. (diff)
downloadgentoo-2-6492435af20d7035fd327994ae0dc91442fbefc4.tar.gz
gentoo-2-6492435af20d7035fd327994ae0dc91442fbefc4.tar.bz2
gentoo-2-6492435af20d7035fd327994ae0dc91442fbefc4.zip
Add missing eutils inherit and update live ebuild to follow the release one.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index dd8b9e8c8f3e..29883ecddb37 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.13 2012/12/09 16:02:37 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.14 2013/01/08 13:28:13 flameeyes Exp $
EAPI=5
-inherit udev git-2
+inherit udev eutils git-2
DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
@@ -23,15 +23,26 @@ src_prepare() {
emake fetch
}
-src_configure() {
- MAKEOPTS+=" UDEV=$(usex udev)"
- MAKEOPTS+=" DOCDIR=${EPREFIX}/usr/share/doc/${PF}"
- MAKEOPTS+=" MISCDIR=${EPREFIX}/usr/share/misc"
- MAKEOPTS+=" HWDBDIR=${EPREFIX}$(udev_get_udevdir)/hwdb.d"
- MAKEOPTS+=" DESTDIR=${D}"
+
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
}
pkg_postinst() {
+ # until udev introduces a way to compile the database at a given
+ # location, rather than just /, we can't do much on offset root.
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+
if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
udevadm hwdb --update
fi