summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-02 09:29:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-02 09:29:03 +0000
commitba546a697092e93410e4a11e27c9d532df0f7fb1 (patch)
treed91f61932b3e214127ea2a118da0f405d552a830 /sys-apps/hwids/hwids-99999999.ebuild
parentAdd missing sys-libs/zlib dependency, wrt bug #424119. Thanks to Agostino Sar... (diff)
downloadgentoo-2-ba546a697092e93410e4a11e27c9d532df0f7fb1.tar.gz
gentoo-2-ba546a697092e93410e4a11e27c9d532df0f7fb1.tar.bz2
gentoo-2-ba546a697092e93410e4a11e27c9d532df0f7fb1.zip
Install missing 20-acpi-vendor.hwdb which seems to be a table of approved ACPI PNP vendors (as per internet search)
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 718d2a576a31..1fd8d734fad8 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.6 2012/12/02 08:13:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.7 2012/12/02 09:29:03 ssuominen Exp $
EAPI=5
inherit udev
@@ -24,12 +24,15 @@ RDEPEND="!<sys-apps/pciutils-3.1.9-r2
src_compile() {
wget http://pci-ids.ucw.cz/v2.2/pci.ids.gz http://www.linux-usb.org/usb.ids.gz http://standards.ieee.org/develop/regauth/oui/oui.txt || die
+ local file
for file in {usb,pci}.ids; do
zcat ${file}.gz > ${file} || die
done
if use udev; then
- wget http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl -O ids-update-${PV}.pl || die
+ local HWDB_URI="http://cgit.freedesktop.org/systemd/systemd/plain/hwdb"
+ wget ${HWDB_URI}/20-acpi-vendor.hwdb || die
+ wget ${HWDB_URI}/ids-update.pl -O ids-update-${PV}.pl || die
perl ids-update-${PV}.pl &>/dev/null || die
fi
}