summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-05-30 14:41:46 +0000
committerMike Frysinger <vapier@gentoo.org>2014-05-30 14:41:46 +0000
commitd4bd7b1f507ab04ffdf40f6a979127bc75ea0377 (patch)
treef4d3dfd0818c9f28eef9095fe62abe2246ac0c15 /sys-apps/hwids/hwids-99999999.ebuild
parentStabilize for everyone else #506026. (diff)
downloadgentoo-2-d4bd7b1f507ab04ffdf40f6a979127bc75ea0377.tar.gz
gentoo-2-d4bd7b1f507ab04ffdf40f6a979127bc75ea0377.tar.bz2
gentoo-2-d4bd7b1f507ab04ffdf40f6a979127bc75ea0377.zip
Simplify the ROOT check in pkg_postinst.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 0d24c6da4c31..384c73fed68e 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.23 2013/08/11 18:59:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.24 2014/05/30 14:41:46 vapier Exp $
EAPI=5
inherit udev eutils git-2
@@ -44,9 +44,6 @@ pkg_postinst() {
if use udev; then
udevadm hwdb --update --root="${ROOT%/}"
# http://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
- if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
- return 0
- fi
- udevadm control --reload
+ [ "${ROOT:-/}" = "/" ] && udevadm control --reload
fi
}