summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-25 17:56:07 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-25 17:56:07 +0000
commit673a5b6965417237a2ed782c89e561ed7b263db9 (patch)
treedfafff9a74ab6fe5422b7655087db142a79cc6ab /sys-apps/initng/initng-0.6.10.1.ebuild
parentold (diff)
downloadgentoo-2-673a5b6965417237a2ed782c89e561ed7b263db9.tar.gz
gentoo-2-673a5b6965417237a2ed782c89e561ed7b263db9.tar.bz2
gentoo-2-673a5b6965417237a2ed782c89e561ed7b263db9.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-apps/initng/initng-0.6.10.1.ebuild')
-rw-r--r--sys-apps/initng/initng-0.6.10.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/initng/initng-0.6.10.1.ebuild b/sys-apps/initng/initng-0.6.10.1.ebuild
new file mode 100644
index 000000000000..6a7ce77ca18a
--- /dev/null
+++ b/sys-apps/initng/initng-0.6.10.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.6.10.1.ebuild,v 1.1 2007/08/25 17:56:07 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="A next generation init replacement"
+HOMEPAGE="http://initng.org/"
+SRC_URI="http://download.initng.org/initng/v${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.1"
+PDEPEND="sys-apps/initng-ifiles"
+
+plugin_warning() {
+ if [[ -z ${INITNG_PLUGINS} ]] ; then
+ einfo "If you want to customize the list of initng plugins, please"
+ einfo "set the INITNG_PLUGINS variable in your make.conf."
+ einfo "See http://www.initng.org/wiki/Documents_Plugins for a list of"
+ einfo "valid plugins for you to choose from."
+ fi
+}
+
+pkg_setup() {
+ plugin_warning
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:-Werror::' CMakeLists.txt #136992
+}
+
+src_compile() {
+ local x default_opts valid_opts cmake_opts=""
+ valid_opts=$(sed -n '/^OPTION/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ default_opts=$(sed -n '/^OPTION(.*ON)$/ s:.*(\([[:alpha:]_]*\).*:\1:p' CMakeLists.txt)
+ INITNG_PLUGINS=$(echo ${INITNG_PLUGINS} | tr '[:lower:]' '[:upper:]')
+ INITNG_PLUGINS=${INITNG_PLUGINS:-${default_opts}}
+ for x in ${valid_opts} ; do
+ if hasq ${x} ${INITNG_PLUGINS} || hasq ${x#BUILD_} ${INITNG_PLUGINS} ; then
+ cmake_opts="${cmake_opts} -D${x}=ON"
+ else
+ cmake_opts="${cmake_opts} -D${x}=OFF"
+ fi
+ done
+ cmake -DCMAKE_INSTALL_PREFIX=/ ${cmake_opts} || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.a' -exec rm "{}" \;
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ plugin_warning
+ einfo "Remember to add init=/sbin/initng in your grub or lilo config"
+ einfo " in order to use initng. Happy testing!"
+}