summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-07 14:48:33 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-07 14:48:33 +0000
commitb7219679e02facf88a54267c6fdc679c8cd8418d (patch)
treecc4dd8c954057d528b395e3b713df1f9e476632c /sys-apps/lvm-user/lvm-user-1.0.6.ebuild
parentfix not detecting gdk-pixbuf-0.20.0 (diff)
downloadgentoo-2-b7219679e02facf88a54267c6fdc679c8cd8418d.tar.gz
gentoo-2-b7219679e02facf88a54267c6fdc679c8cd8418d.tar.bz2
gentoo-2-b7219679e02facf88a54267c6fdc679c8cd8418d.zip
Version bump
Diffstat (limited to 'sys-apps/lvm-user/lvm-user-1.0.6.ebuild')
-rw-r--r--sys-apps/lvm-user/lvm-user-1.0.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/lvm-user/lvm-user-1.0.6.ebuild b/sys-apps/lvm-user/lvm-user-1.0.6.ebuild
new file mode 100644
index 000000000000..a6549d9066a7
--- /dev/null
+++ b/sys-apps/lvm-user/lvm-user-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lvm-user/lvm-user-1.0.6.ebuild,v 1.1 2002/11/07 14:48:33 aliz Exp $
+
+IUSE="static"
+
+inherit flag-o-matic
+
+S=${WORKDIR}/LVM/${PV}
+DESCRIPTION="User-land utilities for LVM (Logical Volume Manager) software"
+SRC_URI="ftp://ftp.sistina.com/pub/LVM/1.0/lvm_${PV}.tar.gz"
+HOMEPAGE="http://www.sistina.com/products_lvm.htm"
+KEYWORDS="~x86 -ppc ~sparc ~sparc64"
+
+DEPEND="virtual/linux-sources"
+RDEPEND="${DEPEND} >=sys-apps/sed-4.0"
+
+LICENSE="GPL-2 | LGPL-2"
+SLOT="0"
+
+KS=/usr/src/linux
+
+src_compile() {
+ local myconf
+
+ # bug 598 -- -pipe used by default
+ filter-flags "-fomit-frame-pointer -pipe"
+
+ use static && myconf="--enable-static_link"
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --with-kernel_dir="${KS}" ${myconf} || die "configure failed"
+
+ # Fix flags
+ sed -i -e "54,56d" -e "73d" make.tmpl
+
+ make || die "Make failed"
+}
+
+src_install() {
+
+ einstall sbindir=${D}/sbin libdir=${D}/lib
+
+ # no need for a static library in /lib
+ dodir /usr/lib
+ mv ${D}/lib/*.a ${D}/usr/lib
+
+ dodoc ABSTRACT CONTRIBUTORS COPYING* INSTALL LVM-HOWTO TODO CHANGELOG FAQ KNOWN_BUGS README WHATSNEW
+}