summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-23 08:18:42 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-23 08:18:42 +0000
commit9ce4cd296bda7a5fb1c66fa7225bbfeb81ce2835 (patch)
treef6a35696c04f0763ce61643c70d5640919384098 /sys-apps/man-db
parentMask broken upnp use flag in kde-base/kdelibs for upcoming stabilization. (diff)
downloadgentoo-2-9ce4cd296bda7a5fb1c66fa7225bbfeb81ce2835.tar.gz
gentoo-2-9ce4cd296bda7a5fb1c66fa7225bbfeb81ce2835.tar.bz2
gentoo-2-9ce4cd296bda7a5fb1c66fa7225bbfeb81ce2835.zip
Version bump (bug #404241).
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog9
-rw-r--r--sys-apps/man-db/man-db-2.6.1.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index ae6ef24802e1..63541f63ac6a 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/man-db
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.25 2011/12/01 17:03:25 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.26 2012/03/23 08:18:42 radhermit Exp $
+
+*man-db-2.6.1 (23 Mar 2012)
+
+ 23 Mar 2012; Tim Harder <radhermit@gentoo.org> +man-db-2.6.1.ebuild:
+ Version bump (bug #404241).
01 Dec 2011; Mike Frysinger <vapier@gentoo.org> man-db-2.6.0.2.ebuild:
Pull in pkg-config for building #392733 by Nikoli.
diff --git a/sys-apps/man-db/man-db-2.6.1.ebuild b/sys-apps/man-db/man-db-2.6.1.ebuild
new file mode 100644
index 000000000000..66ad6bf818f7
--- /dev/null
+++ b/sys-apps/man-db/man-db-2.6.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.1.ebuild,v 1.1 2012/03/23 08:18:42 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="a man replacement that utilizes berkdb instead of flat files"
+HOMEPAGE="http://www.nongnu.org/man-db/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="berkdb +gdbm nls static-libs zlib"
+
+RDEPEND="dev-libs/libpipeline
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ !berkdb? ( !gdbm? ( sys-libs/gdbm ) )
+ sys-apps/groff
+ zlib? ( sys-libs/zlib )
+ !sys-apps/man"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # Create user now as Makefile in src_install does setuid/chown
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_configure() {
+ export ac_cv_lib_z_gzopen=$(usex zlib)
+ econf \
+ --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p tcl n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ --with-db=$(usex gdbm gdbm $(usex berkdb db gdbm))
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc README ChangeLog NEWS docs/{HACKING,TODO}
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+}