summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-13 19:53:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-13 19:53:01 +0000
commit3161bc85cbaaa756da1626f2a8f0abb1fac37e0d (patch)
tree8f09bd71a6e667b5418db561de6d282aad638aa4 /sys-apps/man
parentBump. (Manifest recommit) (diff)
downloadgentoo-2-3161bc85cbaaa756da1626f2a8f0abb1fac37e0d.tar.gz
gentoo-2-3161bc85cbaaa756da1626f2a8f0abb1fac37e0d.tar.bz2
gentoo-2-3161bc85cbaaa756da1626f2a8f0abb1fac37e0d.zip
Fix cross-compiling.
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog6
-rw-r--r--sys-apps/man/files/man-1.5m-cross-compile.patch10
-rw-r--r--sys-apps/man/man-1.5m-r2.ebuild17
3 files changed, 27 insertions, 6 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 5b391cada4e0..7541f7529e00 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.60 2004/11/08 06:15:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.61 2004/12/13 19:53:01 vapier Exp $
+
+ 13 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.5m-cross-compile.patch, man-1.5m-r2.ebuild:
+ Fix cross-compiling.
08 Nov 2004; Mike Frysinger <vapier@gentoo.org> man-1.5m-r2.ebuild:
Install manpath symlink #70278 by Heinrich Rebehn.
diff --git a/sys-apps/man/files/man-1.5m-cross-compile.patch b/sys-apps/man/files/man-1.5m-cross-compile.patch
new file mode 100644
index 000000000000..bd498ae26147
--- /dev/null
+++ b/sys-apps/man/files/man-1.5m-cross-compile.patch
@@ -0,0 +1,10 @@
+--- man-1.5m2/src/Makefile.in.orig 2004-12-13 14:10:10.234084393 -0500
++++ man-1.5m2/src/Makefile.in 2004-12-13 14:10:32.624709119 -0500
+@@ -37,4 +37,7 @@
+
++makemsg:
++ $(BUILD_CC) -o makemsg makemsg.c
++
+ msg.c gripedefs.h: ../msgs/mess.en makemsg
+ ./makemsg ../msgs/mess.en gripedefs.h msg.c
+
diff --git a/sys-apps/man/man-1.5m-r2.ebuild b/sys-apps/man/man-1.5m-r2.ebuild
index 5ee52291fe4d..7bcf09ae5b4e 100644
--- a/sys-apps/man/man-1.5m-r2.ebuild
+++ b/sys-apps/man/man-1.5m-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r2.ebuild,v 1.4 2004/11/12 14:29:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.5m-r2.ebuild,v 1.5 2004/12/13 19:53:01 vapier Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
NV="1.5m2"
DESCRIPTION="Standard commands to read man pages"
@@ -24,8 +24,8 @@ S="${WORKDIR}/${PN}-${NV}"
src_unpack() {
unpack ${A}
+ cd ${S}
- cd "${S}" && \
sed -i \
-e 's:/usr/lib/locale:$(prefix)/usr/lib/locale:g' \
-e 's!/usr/bin:/usr/ucb:!/usr/bin:!' \
@@ -76,14 +76,21 @@ src_unpack() {
# Make sure the locale is searched in the right order #37778
epatch ${FILESDIR}/${P}-locale-order.patch
+ # Fix cross compiling ... a few build apps need to be compiled
+ # with the native gcc instead of target gcc
+ epatch ${FILESDIR}/${P}-cross-compile.patch
+
# use non-lazy binds for man. And let portage handling stripping.
append-ldflags -Wl,-z,now
- sed -i -e \
- s/'LDFLAGS = -s'/"LDFLAGS:=${LDFLAGS}"/g ${S}/src/Makefile.in \
+ sed -i \
+ -e "/^LDFLAGS = -s/s:=.*:=${LDFLAGS}:" \
+ ${S}/src/Makefile.in \
|| die "failed to edit default LDLFAGS"
}
src_compile() {
+ tc-export CC BUILD_CC
+
local myconf=
use nls && myconf="+lang all" || myconf="+lang none"
./configure \