summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-04 08:14:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-04 08:14:11 +0000
commitb0f6d84a0a39acf74d635a250d4c273fa93b2668 (patch)
treef24b2b0f4c0602ad42e569c45aecdc85b6276b7a /sys-apps/minit
parentclosing out bug #41471, marking this x86. (Manifest recommit) (diff)
downloadgentoo-2-b0f6d84a0a39acf74d635a250d4c273fa93b2668.tar.gz
gentoo-2-b0f6d84a0a39acf74d635a250d4c273fa93b2668.tar.bz2
gentoo-2-b0f6d84a0a39acf74d635a250d4c273fa93b2668.zip
initial ebuild
Diffstat (limited to 'sys-apps/minit')
-rw-r--r--sys-apps/minit/ChangeLog8
-rw-r--r--sys-apps/minit/files/0.9.1-destdir.patch16
-rw-r--r--sys-apps/minit/files/digest-minit-0.9.11
-rw-r--r--sys-apps/minit/metadata.xml22
-rw-r--r--sys-apps/minit/minit-0.9.1.ebuild30
5 files changed, 77 insertions, 0 deletions
diff --git a/sys-apps/minit/ChangeLog b/sys-apps/minit/ChangeLog
new file mode 100644
index 000000000000..534ad6973e47
--- /dev/null
+++ b/sys-apps/minit/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-apps/minit
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/minit/ChangeLog,v 1.1 2004/03/04 08:14:11 vapier Exp $
+
+*minit-0.9.1 (04 Mar 2004)
+
+ 04 Mar 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me for wmertens.
diff --git a/sys-apps/minit/files/0.9.1-destdir.patch b/sys-apps/minit/files/0.9.1-destdir.patch
new file mode 100644
index 000000000000..7a36d3cdfde7
--- /dev/null
+++ b/sys-apps/minit/files/0.9.1-destdir.patch
@@ -0,0 +1,16 @@
+--- Makefile.orig 2004-03-04 03:08:18.967017104 -0500
++++ Makefile 2004-03-04 03:10:11.445917712 -0500
+@@ -36,10 +36,12 @@
+ $(DIET) $(CROSS)$(CC) $(CFLAGS) -o $@ $^
+
+ install-files:
++ test -d $(DESTDIR)/sbin || mkdir -p $(DESTDIR)/sbin
+ install minit pidfilehack $(DESTDIR)/sbin
+ install write_proc hard-reboot $(DESTDIR)/sbin
++ test -d $(DESTDIR)/bin || mkdir -p $(DESTDIR)/bin
+ install msvc $(DESTDIR)/bin
+- test -d $(DESTDIR)/etc/minit || mkdir $(DESTDIR)/etc/minit
++ test -d $(DESTDIR)/etc/minit || mkdir -p $(DESTDIR)/etc/minit
+
+ install-fifos:
+ -mkfifo -m 600 $(DESTDIR)/etc/minit/in $(DESTDIR)/etc/minit/out
diff --git a/sys-apps/minit/files/digest-minit-0.9.1 b/sys-apps/minit/files/digest-minit-0.9.1
new file mode 100644
index 000000000000..e00c54344b14
--- /dev/null
+++ b/sys-apps/minit/files/digest-minit-0.9.1
@@ -0,0 +1 @@
+MD5 c4e98bb5ceb03d9a74e8bbaf1e6e5b01 minit-0.9.1.tar.bz2 21894
diff --git a/sys-apps/minit/metadata.xml b/sys-apps/minit/metadata.xml
new file mode 100644
index 000000000000..2bbbccc887b0
--- /dev/null
+++ b/sys-apps/minit/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<longdescription>
+minit - a small yet feature-complete init
+
+What works so far
+ * It can start services and take dependencies into account.
+ * It can restart services
+ * It can start services in sync mode (i.e. wait until they
+terminate, to get around race conditions for static initializations)
+ * There is a companion utility "msvc" that can be used much in the
+same way as the svc from daemontools. Communication works over two
+fifos, /etc/minit/in and /etc/minit/out. Those have to exist before
+minit is started and they should be owned by root and have mode 600.
+ * There is a companion utility "pidfilehack" that can be used to do
+stuff like run ssh, wait a while, read the PID off /var/run/sshd.pid and
+tell minit this PID so it will know when sshd exits and can restart it.
+ * It can pipe stdout to a dedicated log process.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-apps/minit/minit-0.9.1.ebuild b/sys-apps/minit/minit-0.9.1.ebuild
new file mode 100644
index 000000000000..e91bfb91effa
--- /dev/null
+++ b/sys-apps/minit/minit-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/minit/minit-0.9.1.ebuild,v 1.1 2004/03/04 08:14:11 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a small yet feature-complete init"
+HOMEPAGE="http://www.fefe.de/minit/"
+SRC_URI="http://www.fefe.de/minit/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-libs/dietlibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-destdir.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc CHANGES README TODO
+}