summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-01 01:09:23 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-01 01:09:23 +0000
commitdbfbc586bcb7e16f4fa5e647e7f2dc3cbf3d5098 (patch)
treeefe40166291fa9fd76ce5bcb84d170364f54757b /sys-apps/pmount
parentCOPYING does not exist, bug #257160. (diff)
downloadgentoo-2-dbfbc586bcb7e16f4fa5e647e7f2dc3cbf3d5098.tar.gz
gentoo-2-dbfbc586bcb7e16f4fa5e647e7f2dc3cbf3d5098.tar.bz2
gentoo-2-dbfbc586bcb7e16f4fa5e647e7f2dc3cbf3d5098.zip
Bump to 0.9.18, bug #252954. Make it find cryptsetup, bug #205935. Install pmount setgid, bug #250106.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/pmount')
-rw-r--r--sys-apps/pmount/ChangeLog8
-rw-r--r--sys-apps/pmount/pmount-0.9.18.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/pmount/ChangeLog b/sys-apps/pmount/ChangeLog
index e3661654896a..872261a4cbef 100644
--- a/sys-apps/pmount/ChangeLog
+++ b/sys-apps/pmount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/pmount
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.61 2009/01/13 15:20:43 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/ChangeLog,v 1.62 2009/02/01 01:09:23 eva Exp $
+
+*pmount-0.9.18 (01 Feb 2009)
+
+ 01 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org> +pmount-0.9.18.ebuild:
+ Bump to 0.9.18, bug #252954. Make it find cryptsetup, bug #205935. Install
+ pmount setgid, bug #250106.
13 Jan 2009; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
gentopia is becoming freedesktop
diff --git a/sys-apps/pmount/pmount-0.9.18.ebuild b/sys-apps/pmount/pmount-0.9.18.ebuild
new file mode 100644
index 000000000000..b3259d77b898
--- /dev/null
+++ b/sys-apps/pmount/pmount-0.9.18.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pmount/pmount-0.9.18.ebuild,v 1.1 2009/02/01 01:09:23 eva Exp $
+
+inherit eutils
+
+DESCRIPTION="Policy based mounter that gives the ability to mount removable devices as a user"
+HOMEPAGE="http://pmount.alioth.debian.org/"
+SRC_URI="http://alioth.debian.org/frs/download.php/2624/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="crypt hal"
+
+RDEPEND="hal? ( >=sys-apps/dbus-0.33 >=sys-apps/hal-0.5.2 )
+ >=sys-fs/sysfsutils-1.3.0
+ crypt? ( >=sys-fs/cryptsetup-1.0.5 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40"
+
+# Newly introduced test suite fails.
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_compile() {
+ econf $(use_enable hal)
+ emake || die "emake failed"
+}
+
+src_install () {
+ # this is where we mount stuff
+ # moved to hal as of 0.5.7-r1
+ #keepdir /media
+
+ # Must be run SETUID+SETGID, bug #250106
+ exeinto /usr/bin
+ exeopts -m 6710 -g plugdev
+ doexe src/pmount src/pumount src/pmount-hal
+
+ dodoc AUTHORS ChangeLog TODO
+ doman man/pmount.1 man/pumount.1 man/pmount-hal.1
+
+ insinto /etc
+ doins etc/pmount.allow
+}
+
+pkg_postinst() {
+ elog
+ elog "This package has been installed setuid and setgid."
+
+ elog "The permissions are as such that only users that belong to the plugdev"
+ elog "group are allowed to run this. But if a script run by root mounts a"
+ elog "device, members of the plugdev group will have access to it."
+ elog
+ elog "Please add your user to the plugdev group to be able to mount USB drives"
+}