summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-10-21 13:40:58 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-10-21 13:40:58 +0000
commitd63ad995e7be8a9ffe84350b87ca52b5d833fa55 (patch)
tree05fbf08ac7af1cee7653716d89b0705f77a8ac4a /sys-apps/qingy/qingy-0.2.3.ebuild
parentfixing Manifest (diff)
downloadgentoo-2-d63ad995e7be8a9ffe84350b87ca52b5d833fa55.tar.gz
gentoo-2-d63ad995e7be8a9ffe84350b87ca52b5d833fa55.tar.bz2
gentoo-2-d63ad995e7be8a9ffe84350b87ca52b5d833fa55.zip
version bump
Diffstat (limited to 'sys-apps/qingy/qingy-0.2.3.ebuild')
-rw-r--r--sys-apps/qingy/qingy-0.2.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/qingy/qingy-0.2.3.ebuild b/sys-apps/qingy/qingy-0.2.3.ebuild
new file mode 100644
index 000000000000..299e4c31220a
--- /dev/null
+++ b/sys-apps/qingy/qingy-0.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/qingy/qingy-0.2.3.ebuild,v 1.1 2003/10/21 13:40:58 pyrania Exp $
+
+DESCRIPTION="Qingy is a DirectFB getty replacement."
+HOMEPAGE="http://qingy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pam"
+DEPEND=">=dev-libs/DirectFB-0.9.18
+ pam? ( >=sys-libs/pam-0.75-r11 )"
+S=${WORKDIR}/${P}
+
+src_compile()
+{
+ econf || die
+
+ emake || die
+}
+
+src_install()
+{
+ # create some dirs
+ mkdir -m 755 ${D}etc
+ use pam && mkdir -m 755 ${D}etc/pam.d
+ mkdir -m 755 ${D}sbin
+
+ # copy documentation manually as make install doesn't do that
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README HOWTO_THEMES
+
+ # and finally install the program
+ make prefix=${D} install || die
+}
+
+pkg_postinst ()
+{
+ einfo "In order to use qingy you must first edit your /etc/inittab"
+ einfo "Check files INSTALL and README in /usr/share/doc/${P}"
+ einfo "for instructions on how to do that."
+}