summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-05-17 02:47:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-05-17 02:47:40 +0000
commit1f17198fced7febd79ccd85916bca8a1025d9de0 (patch)
tree27ca84e9d5c78e8defee7d8bdee661d81396621a /sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild
parentold (diff)
downloadgentoo-2-1f17198fced7febd79ccd85916bca8a1025d9de0.tar.gz
gentoo-2-1f17198fced7febd79ccd85916bca8a1025d9de0.tar.bz2
gentoo-2-1f17198fced7febd79ccd85916bca8a1025d9de0.zip
New release, fixing bug #92714.
(Portage version: 2.0.51.21)
Diffstat (limited to 'sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild')
-rw-r--r--sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild b/sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild
new file mode 100644
index 000000000000..d58218e2f3c5
--- /dev/null
+++ b/sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/readahead-list/readahead-list-0.20050517.0220.ebuild,v 1.1 2005/05/17 02:47:40 robbat2 Exp $
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading."
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="http://tirpitz.iat.sfu.ca/custom-software/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+# I'm not entirely certain about this
+# need to check if other libc variants provide readahead(2)
+RDEPEND="virtual/libc"
+# the blocked headers are broken
+# they don't compile properly!
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_compile() {
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # init scripts
+ cd "${S}/contrib/init/gentoo/"
+ newinitd init.d-readahead-list readahead-list
+ newinitd init.d-readahead-list-early readahead-list-early
+ newconfd conf.d-readahead-list readahead-list
+
+ # default config
+ insinto /etc/readahead-list
+ cd "${S}/contrib/data"
+ newins readahead.runlevel-default.list runlevel-default
+ newins readahead.runlevel-boot.list runlevel-boot
+ newins readahead._sbin_rc.list exec_sbin_rc
+
+ # docs
+ cd "${S}"
+ dodoc README
+ if use doc; then
+ docinto scripts
+ dodoc contrib/scripts/*
+ fi
+ # clean up a bit
+ find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{} \;
+}
+
+pkg_postinst() {
+ einfo "You should add readahead-list to your runlevels:"
+ einfo " rc-update add readahead-list-early boot"
+ einfo " rc-update add readahead-list boot"
+ einfo "Also consider customizing the lists in /etc/readahead-list"
+ einfo "for maximum performance gain."
+}