summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-08 04:43:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-08 04:43:34 +0000
commitc94f5fd3b8d49e4cc8264af80f681cfb0207e183 (patch)
treefebd71c1c7332a6d31f33f39050677496c4b47b2 /sys-apps/rkflashtool
parentbump; patch preventing un-needed d'loading in doc build (diff)
downloadgentoo-2-c94f5fd3b8d49e4cc8264af80f681cfb0207e183.tar.gz
gentoo-2-c94f5fd3b8d49e4cc8264af80f681cfb0207e183.tar.bz2
gentoo-2-c94f5fd3b8d49e4cc8264af80f681cfb0207e183.zip
Version bump. Respect CC, CFLAGS, LDFLAGS. Remove old.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'sys-apps/rkflashtool')
-rw-r--r--sys-apps/rkflashtool/ChangeLog10
-rw-r--r--sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h5
-rw-r--r--sys-apps/rkflashtool/rkflashtool-5.1.ebuild34
3 files changed, 47 insertions, 2 deletions
diff --git a/sys-apps/rkflashtool/ChangeLog b/sys-apps/rkflashtool/ChangeLog
index 18b5c6c139b8..c014990c7618 100644
--- a/sys-apps/rkflashtool/ChangeLog
+++ b/sys-apps/rkflashtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rkflashtool
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rkflashtool/ChangeLog,v 1.1 2013/11/14 01:47:27 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rkflashtool/ChangeLog,v 1.2 2014/01/08 04:43:34 mrueg Exp $
+
+*rkflashtool-5.1 (08 Jan 2014)
+
+ 08 Jan 2014; Manuel Rüger <mrueg@gentoo.org>
+ +files/rkflashtool-5.1-missing-version.h, +rkflashtool-5.1.ebuild:
+ Version bump. Respect CC, CFLAGS, LDFLAGS. Remove old.
*rkflashtool-5.0 (14 Nov 2013)
diff --git a/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h b/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h
new file mode 100644
index 000000000000..bfffda893a2f
--- /dev/null
+++ b/sys-apps/rkflashtool/files/rkflashtool-5.1-missing-version.h
@@ -0,0 +1,5 @@
+#ifndef RKFLASHTOOL_VERSION_H
+#define RKFLASHTOOL_VERSION_H
+#define RKFLASHTOOL_VERSION_MAJOR 5
+#define RKFLASHTOOL_VERSION_MINOR 1
+#endif
diff --git a/sys-apps/rkflashtool/rkflashtool-5.1.ebuild b/sys-apps/rkflashtool/rkflashtool-5.1.ebuild
new file mode 100644
index 000000000000..79daf483cf1b
--- /dev/null
+++ b/sys-apps/rkflashtool/rkflashtool-5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rkflashtool/rkflashtool-5.1.ebuild,v 1.1 2014/01/08 04:43:34 mrueg Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for flashing Rockchip devices"
+HOMEPAGE="http://sourceforge.net/projects/rkflashtool/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}/${P}-src.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S=${WORKDIR}/${P}-src
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ cp "${FILESDIR}"/${P}-missing-version.h version.h || die
+ sed -i -e "s/CC =/CC ?=/"\
+ -e "s/CFLAGS =/CFLAGS ?=/"\
+ -e "s/LDFLAGS =/LDFLAGS ?=/" Makefile || die
+ tc-export CC
+}
+
+src_install(){
+ dodoc README
+ dobin ${PN} rkcrc rkflashtool rkmisc rkpad rkparameters rkparametersblock rkunpack rkunsign
+}