summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-27 05:41:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-27 05:41:22 +0000
commit769582074b37bbb5b52fa3873b38630c954fe62d (patch)
treeb5584c862c3a913d80680f4cf3a20c92541b4d77 /sys-apps/rlocate
parentRemoved ppc\'s dep on lib-compat. Added dependency on =virtual/libstdc++-3.3 ... (diff)
downloadgentoo-2-769582074b37bbb5b52fa3873b38630c954fe62d.tar.gz
gentoo-2-769582074b37bbb5b52fa3873b38630c954fe62d.tar.bz2
gentoo-2-769582074b37bbb5b52fa3873b38630c954fe62d.zip
Version bump.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sys-apps/rlocate')
-rw-r--r--sys-apps/rlocate/ChangeLog8
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.5.33
-rw-r--r--sys-apps/rlocate/files/rlocate-0.5.3-build.patch21
-rw-r--r--sys-apps/rlocate/rlocate-0.5.3.ebuild48
4 files changed, 79 insertions, 1 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index 74a261c01055..8735e26e639e 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.18 2006/09/23 11:03:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.19 2006/09/27 05:41:22 vapier Exp $
+
+*rlocate-0.5.3 (27 Sep 2006)
+
+ 27 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/rlocate-0.5.3-build.patch, +rlocate-0.5.3.ebuild:
+ Version bump.
23 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+files/rlocate-0.5.2-utsversion.patch, rlocate-0.5.2.ebuild:
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.5.3 b/sys-apps/rlocate/files/digest-rlocate-0.5.3
new file mode 100644
index 000000000000..c056217b1ce5
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.5.3
@@ -0,0 +1,3 @@
+MD5 565f279b3c6ccfdf6a5b2a80e42bfe3e rlocate-0.5.3.tar.gz 181867
+RMD160 642d5b277928285d9cd518c47be7a358bc0b8456 rlocate-0.5.3.tar.gz 181867
+SHA256 25d8392ed1a7e97caf6898132cad0af9bb51a0e80ed1403164f87487f3500b04 rlocate-0.5.3.tar.gz 181867
diff --git a/sys-apps/rlocate/files/rlocate-0.5.3-build.patch b/sys-apps/rlocate/files/rlocate-0.5.3-build.patch
new file mode 100644
index 000000000000..35dc5d74d624
--- /dev/null
+++ b/sys-apps/rlocate/files/rlocate-0.5.3-build.patch
@@ -0,0 +1,21 @@
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -190,7 +190,7 @@
+ rlocate.h rlocate.c cmds.c cmds.h conf.c conf.h utils.c \
+ utils.h
+
+-SUBDIRS = rlocate-daemon rlocate-module rlocate-scripts
++SUBDIRS = rlocate-daemon rlocate-scripts
+ EXTRA_DIST = rlocate.cron rlocate-scripts install-cron.sh.in
+ AM_CFLAGS =
+ all: all-recursive
+--- src/rlocate-scripts/Makefile.in
++++ src/rlocate-scripts/Makefile.in
+@@ -343,7 +343,6 @@
+ rm $(srcdir)/rlocate-checkpoint.temp
+
+ install-exec-hook:
+- -/usr/sbin/groupadd $(rlocate_group)
+ chown $(root_uid):$(rlocate_group) $(DESTDIR)$(bindir)/rlocate-checkpoint
+ chmod 2755 $(DESTDIR)$(bindir)/rlocate-checkpoint
+
diff --git a/sys-apps/rlocate/rlocate-0.5.3.ebuild b/sys-apps/rlocate/rlocate-0.5.3.ebuild
new file mode 100644
index 000000000000..eaee35f79053
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.5.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.5.3.ebuild,v 1.1 2006/09/27 05:41:22 vapier Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/src/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.3-build.patch
+}
+
+src_compile() {
+ econf \
+ --with-kernel=${KV_DIR} \
+ --with-rlocate-group=locate \
+ || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ newinitd "${FILESDIR}"/rlocated.rc rlocated
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}