summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-23 12:30:14 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-23 12:30:14 +0000
commit4c995cebb4c787c7dcf37b57de29c7db6218dad7 (patch)
tree8f3baf00ee47839210886edb0383e66be38554ae /sys-apps/sandbox
parentSync live ebuild with latest snapshot; merely add speex useflag and remove un... (diff)
downloadgentoo-2-4c995cebb4c787c7dcf37b57de29c7db6218dad7.tar.gz
gentoo-2-4c995cebb4c787c7dcf37b57de29c7db6218dad7.tar.bz2
gentoo-2-4c995cebb4c787c7dcf37b57de29c7db6218dad7.zip
Fix some portability issues and more *at updates.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog7
-rw-r--r--sys-apps/sandbox/sandbox-1.3.2.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 89888d36828d..3aee7aeed809 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.95 2008/12/09 12:31:09 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.96 2008/12/23 12:30:14 vapier Exp $
+
+*sandbox-1.3.2 (23 Dec 2008)
+
+ 23 Dec 2008; Mike Frysinger <vapier@gentoo.org> +sandbox-1.3.2.ebuild:
+ Fix some portability issues and more *at updates.
09 Dec 2008; Alexis Ballier <aballier@gentoo.org> sandbox-1.3.0.ebuild,
sandbox-1.3.1.ebuild:
diff --git a/sys-apps/sandbox/sandbox-1.3.2.ebuild b/sys-apps/sandbox/sandbox-1.3.2.ebuild
new file mode 100644
index 000000000000..f9ef97724947
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.3.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.3.2.ebuild,v 1.1 2008/12/23 12:30:14 vapier Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.lzma
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+
+EMULTILIB_PKG="true"
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS="${EBUILD_DEATH_HOOKS} sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+}
+
+src_compile() {
+ filter-lfs-flags #90228
+
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ mkdir "${WORKDIR}/build-${ABI}"
+ cd "${WORKDIR}/build-${ABI}"
+
+ multilib_toolchain_setup ${ABI}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf ${myconf} || die
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || die
+ done
+ ABI=${OABI}
+}
+
+src_test() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Checking sandbox for ABI=${ABI}..."
+ emake check || die "make check failed for ${ABI}"
+ done
+ ABI=${OABI}
+}
+
+src_install() {
+ local OABI=${ABI}
+ for ABI in $(get_install_abis) ; do
+ cd "${WORKDIR}/build-${ABI}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ emake DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ doenvd "${FILESDIR}"/09sandbox
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd "${S}"
+ dodoc AUTHORS ChangeLog* NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage "${D}"/var/log/sandbox
+ chmod 0770 "${D}"/var/log/sandbox
+}