summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-10-23 23:47:28 +0000
committerMike Frysinger <vapier@gentoo.org>2007-10-23 23:47:28 +0000
commit9dc8efc8e2615aa0e6dcba31435327d003b1325d (patch)
treeb60435ed2aef0b752c321bf1e6a92f320c760be8 /sys-apps/sandbox
parentcompiz-fusion initial commit (diff)
downloadgentoo-2-9dc8efc8e2615aa0e6dcba31435327d003b1325d.tar.gz
gentoo-2-9dc8efc8e2615aa0e6dcba31435327d003b1325d.tar.bz2
gentoo-2-9dc8efc8e2615aa0e6dcba31435327d003b1325d.zip
Work with new "e" fopen() flag in glibc-2.7 #196720.
(Portage version: 2.1.3.15)
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/ChangeLog8
-rw-r--r--sys-apps/sandbox/files/digest-sandbox-1.2.18.1-r23
-rw-r--r--sys-apps/sandbox/files/sandbox-1.2.18.1-open-cloexec.patch15
-rw-r--r--sys-apps/sandbox/sandbox-1.2.18.1-r2.ebuild121
4 files changed, 146 insertions, 1 deletions
diff --git a/sys-apps/sandbox/ChangeLog b/sys-apps/sandbox/ChangeLog
index 22c3b23d5707..2f9d6740ad9e 100644
--- a/sys-apps/sandbox/ChangeLog
+++ b/sys-apps/sandbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sandbox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.77 2007/10/17 15:55:16 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/ChangeLog,v 1.78 2007/10/23 23:47:27 vapier Exp $
+
+*sandbox-1.2.18.1-r2 (23 Oct 2007)
+
+ 23 Oct 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/sandbox-1.2.18.1-open-cloexec.patch, +sandbox-1.2.18.1-r2.ebuild:
+ Work with new "e" fopen() flag in glibc-2.7 #196720.
*sandbox-1.2.18.1-r1 (17 Oct 2007)
diff --git a/sys-apps/sandbox/files/digest-sandbox-1.2.18.1-r2 b/sys-apps/sandbox/files/digest-sandbox-1.2.18.1-r2
new file mode 100644
index 000000000000..f894e17eaa8e
--- /dev/null
+++ b/sys-apps/sandbox/files/digest-sandbox-1.2.18.1-r2
@@ -0,0 +1,3 @@
+MD5 8637808ea8fa55fe10c57d335911e847 sandbox-1.2.18.1.tar.bz2 236755
+RMD160 62e1e33d7f64db14d9c34d103d50256934a6d253 sandbox-1.2.18.1.tar.bz2 236755
+SHA256 3404381bfdea3042e6ddb7c309eaef08201d8731d8e0a756c42cd389edda14c0 sandbox-1.2.18.1.tar.bz2 236755
diff --git a/sys-apps/sandbox/files/sandbox-1.2.18.1-open-cloexec.patch b/sys-apps/sandbox/files/sandbox-1.2.18.1-open-cloexec.patch
new file mode 100644
index 000000000000..806f1a3a6773
--- /dev/null
+++ b/sys-apps/sandbox/files/sandbox-1.2.18.1-open-cloexec.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/196720
+
+mark the new "e" fopen() flag as safe
+
+--- sandbox-1.2.18.1/src/libsandbox.c
++++ sandbox-1.2.18.1/src/libsandbox.c
+@@ -1595,7 +1595,7 @@
+ {
+ if (*mode == 'r' && (0 == (strcmp(mode, "r")) ||
+ /* The strspn accept args are known non-writable modifiers */
+- (strlen(++mode) == strspn(mode, "xbtmc")))) {
++ (strlen(++mode) == strspn(mode, "xbtmce")))) {
+ return before_syscall("open_rd", file);
+ } else {
+ return before_syscall("open_wr", file);
diff --git a/sys-apps/sandbox/sandbox-1.2.18.1-r2.ebuild b/sys-apps/sandbox/sandbox-1.2.18.1-r2.ebuild
new file mode 100644
index 000000000000..d28f2cbed286
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-1.2.18.1-r2.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.2.18.1-r2.ebuild,v 1.1 2007/10/23 23:47:27 vapier Exp $
+
+#
+# don't monkey with this ebuild unless contacting portage devs.
+# period.
+#
+
+inherit eutils flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~azarah/sandbox/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+EMULTILIB_PKG="true"
+
+setup_multilib() {
+ if use amd64 && has_m32 && [[ ${CONF_MULTILIBDIR} == "lib32" ]]; then
+ export DEFAULT_ABI="amd64"
+ export MULTILIB_ABIS="x86 amd64"
+ export CFLAGS_amd64=${CFLAGS_amd64:-"-m64"}
+ export CFLAGS_x86=${CFLAGS_x86-"-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"}
+ export CHOST_amd64="x86_64-pc-linux-gnu"
+ export CHOST_x86="i686-pc-linux-gnu"
+ export LIBDIR_amd64=${LIBDIR_amd64-${CONF_LIBDIR}}
+ export LIBDIR_x86=${LIBDIR_x86-${CONF_MULTILIBDIR}}
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-open-normal-fail.patch #135745
+ epatch "${FILESDIR}"/${P}-open-cloexec.patch #196720
+}
+
+abi_fail_check() {
+ local ABI=$1
+ if [[ ${ABI} == "x86" ]] ; then
+ echo
+ eerror "Building failed for ABI=x86!. This usually means a broken"
+ eerror "multilib setup. Please fix that before filling a bugreport"
+ eerror "against sandbox."
+ echo
+ fi
+}
+
+src_compile() {
+ local myconf
+ local iscross=0
+
+ setup_multilib
+
+ filter-lfs-flags #90228
+
+ has_multilib_profile && myconf="--enable-multilib"
+
+ ewarn "If configure fails with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES=-sandbox emerge sandbox"
+
+ [[ -n ${CBUILD} && ${CBUILD} != ${CHOST} ]] && iscross=1
+
+ OABI=${ABI}
+ OCHOST=${CHOST}
+ for ABI in $(get_install_abis); do
+ mkdir "${WORKDIR}/build-${ABI}-${OCHOST}"
+ cd "${WORKDIR}/build-${ABI}-${OCHOST}"
+
+ # Needed for older broken portage versions (bug #109036)
+ has_version '<sys-apps/portage-2.0.51.22' && \
+ unset EXTRA_ECONF
+
+ export ABI
+ export CHOST=$(get_abi_CHOST)
+ [[ ${iscross} == 0 ]] && export CBUILD=${CHOST}
+
+ einfo "Configuring sandbox for ABI=${ABI}..."
+ ECONF_SOURCE="../${P}/" \
+ econf --libdir="/usr/$(get_libdir)" ${myconf}
+ einfo "Building sandbox for ABI=${ABI}..."
+ emake || {
+ abi_fail_check "${ABI}"
+ die "emake failed for ${ABI}"
+ }
+ done
+ ABI=${OABI}
+ CHOST=${OCHOST}
+}
+
+src_install() {
+ setup_multilib
+
+ OABI=${ABI}
+ for ABI in $(get_install_abis); do
+ cd "${WORKDIR}/build-${ABI}-${CHOST}"
+ einfo "Installing sandbox for ABI=${ABI}..."
+ make DESTDIR="${D}" install || die "make install failed for ${ABI}"
+ done
+ ABI=${OABI}
+
+ keepdir /var/log/sandbox
+ fowners root:portage /var/log/sandbox
+ fperms 0770 /var/log/sandbox
+
+ cd ${S}
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ chown root:portage ${D}/var/log/sandbox
+ chmod 0770 ${D}/var/log/sandbox
+}