summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-08 23:24:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-08 23:24:04 +0000
commit54a1ec207a1d74e9debe4a490e0fcb65707887f9 (patch)
tree95eaf05cd65ff40dc26787cf1eb3b9659db35061 /sys-apps/sed
parentMark 079-r1 stable on alpha (diff)
downloadgentoo-2-54a1ec207a1d74e9debe4a490e0fcb65707887f9.tar.gz
gentoo-2-54a1ec207a1d74e9debe4a490e0fcb65707887f9.tar.bz2
gentoo-2-54a1ec207a1d74e9debe4a490e0fcb65707887f9.zip
Remove compat symlinks; hardcoding paths is bad mmmkay #122082 Christoph Schulz.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog8
-rw-r--r--sys-apps/sed/files/digest-sed-4.1.4-r11
-rw-r--r--sys-apps/sed/sed-4.1.4-r1.ebuild73
3 files changed, 81 insertions, 1 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 1e674eaa89b8..54f802ffa075 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/sed
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.67 2006/01/13 19:42:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.68 2006/02/08 23:24:04 vapier Exp $
+
+*sed-4.1.4-r1 (08 Feb 2006)
+
+ 08 Feb 2006; Mike Frysinger <vapier@gentoo.org> +sed-4.1.4-r1.ebuild:
+ Remove compat symlinks; hardcoding paths is bad mmmkay #122082 Christoph
+ Schulz.
13 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> sed-4.0.9.ebuild,
sed-4.1.4.ebuild:
diff --git a/sys-apps/sed/files/digest-sed-4.1.4-r1 b/sys-apps/sed/files/digest-sed-4.1.4-r1
new file mode 100644
index 000000000000..6416834b96c3
--- /dev/null
+++ b/sys-apps/sed/files/digest-sed-4.1.4-r1
@@ -0,0 +1 @@
+MD5 2a62ceadcb571d2dac006f81df5ddb48 sed-4.1.4.tar.gz 794257
diff --git a/sys-apps/sed/sed-4.1.4-r1.ebuild b/sys-apps/sed/sed-4.1.4-r1.ebuild
new file mode 100644
index 000000000000..a368e4a8fd5f
--- /dev/null
+++ b/sys-apps/sed/sed-4.1.4-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.4-r1.ebuild,v 1.1 2006/02/08 23:24:04 vapier Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Super-useful stream editor"
+HOMEPAGE="http://sed.sourceforge.net/"
+SRC_URI="mirror://gnu/sed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm amd64 hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc x86"
+IUSE="nls static build bootstrap"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_bootstrap_sed() {
+ # make sure system-sed works #40786
+ export NO_SYS_SED=""
+ if ! use bootstrap && ! use build ; then
+ if ! type -p sed ; then
+ NO_SYS_SED="!!!"
+ ./bootstrap.sh || die "couldnt bootstrap"
+ cp sed/sed ${T}/ || die "couldnt copy"
+ export PATH="${PATH}:${T}"
+ fi
+ fi
+}
+src_bootstrap_cleanup() {
+ if [[ -n ${NO_SYS_SED} ]] ; then
+ make clean || die "couldnt clean"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makeinfo-c-locale.patch
+ epatch "${FILESDIR}"/${P}-fix-invalid-ref-error.patch
+ sed -i \
+ -e "/docdir =/s:/doc:/doc/${PF}/html:" \
+ doc/Makefile.in || die "sed html doc"
+}
+
+src_compile() {
+ src_bootstrap_sed
+
+ local myconf=""
+ if [[ ${CHOST} != *-gnu ]] ; then
+ myconf="--program-prefix=g"
+ fi
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "Configure failed"
+
+ src_bootstrap_cleanup
+ use static && append-ldflags -static
+ emake LDFLAGS="${LDFLAGS}" || die "build failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
+ docinto examples
+ dodoc "${FILESDIR}"/{dos2unix,unix2dos}
+
+ rm -f "${D}"/usr/lib/charset.alias "${D}"/usr/share/locale/locale.alias
+}